Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Reply
 
Thread Tools Search this Thread
Old Aug 15, 2006, 9:53 PM   #1
Senior Member
 
aytheon's Avatar
 
Join Date: Jul 2006
Posts: 230
Default

Im having a real problem getting the filters clean and smudge free.
All of my filters are Hoya multi coat filters and when i clean them all i get is smudges.
I bought a cleaning kit localy it came with a bottle of de-natured alcohol and some soft cloth wipes. it works well on the camera lens no problem. but on the filters its becoming a nightmare, and even when i finaly get it clean there is a small ring at the outer edge on the filter that the cloth cant get to.
Any suggestion are welcome

Will
aytheon is offline   Reply With Quote
Sponsored Links
Old Aug 15, 2006, 10:05 PM   #2
Senior Member
 
Boily's Avatar
 
Join Date: Jul 2005
Posts: 3,704
Default

I bought this little cleaning kit at walmart and it is perfect !!


Boily is offline   Reply With Quote
Old Aug 15, 2006, 10:40 PM   #3
Senior Member
 
bill2468's Avatar
 
Join Date: Dec 2004
Posts: 1,936
Default

Sounds like you are using too much fluid. Put a drop on a folded lens tissue and start from the center and avoid having any fluid run free down into where lens elements touch barrel of lens. Wipe dry but exhale on lens first so a dry tissue (or a clean dry cotton swab)wont scratch lens.

BiLL

:|
bill2468 is offline   Reply With Quote
Old Aug 16, 2006, 12:48 AM   #4
Senior Member
 
aytheon's Avatar
 
Join Date: Jul 2006
Posts: 230
Default

Thanks boily and bill im gonna give them a try

will
aytheon is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:42 AM.