Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Konica Minolta (https://forums.steves-digicams.com/konica-minolta-26/)
-   -   Please help, Konica X21 (https://forums.steves-digicams.com/konica-minolta-26/please-help-konica-x21-39871/)

ken2k7 Dec 8, 2004 7:38 PM



I bought a Konica Minolta X21.

Soon after buying the camera from ebay, i noticed that when i put in batteries the camera wont start up. But when i open and close the battery slot, it then works.

About a week later, even if i open and close the slot it, the camera still doesnt work. But if i push and hold on the batter slot then it works, but if i let go then the camera goes dead.

I Know for sure that the power from the batteries isnt reaching the camera.

how would i fix this?

Thanx in advance.

sensovision Dec 8, 2004 8:03 PM

hi ken2k7! I own X20 about year ago, it's great camera and I never had any issues with power with it. I guess that your camera is second hand am I right? and if so the problems you experienced may be caused by leaking of battaries or because connectors isn't provide good connection between battaries and camera power system, As for fixing, I guess that if the place you live have Minolta support nearby you may visit them and consult about this problem, maybe this is something more serious(although I doubt), but if you live in the place(like I am) where no Minolta support available you could try to fix it yourself(if you not familliar with electronic devices maybe find a friend who could deal with them better?) you could try to examine if connectors have an oxid on them and if it present you could try to remove it from them. If oxid is on internal connectors I'm not sure if you would be able to reach them without disassembling camera(which I strongly advice not to do in any case)...
Hope that cleaning of connectors would solve you problem and save you money for going to service center.


All times are GMT -5. The time now is 1:31 PM.