Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Konica Minolta (https://forums.steves-digicams.com/konica-minolta-26/)
-   -   Z3 Failure (https://forums.steves-digicams.com/konica-minolta-26/z3-failure-35097/)

Stuporzoom Oct 6, 2004 8:48 PM

Sorry to report that I had major problems with my Z3.

From the start uploading pics to the computer via the USB cable was painful, locking up and needing a reboot every few images. Minolta rep was advised and promised to investigate and advise. Was planning to get a reader anyway, so maybe not a dealbreaker.

Big trouble came after 7 days of use, blank dimly lit screen on bootup...only displaying an image after cycling through the viewfinder select switch. Zoom disabled. Camera broken!:?

Back to the dealer were I am relieved to say I got a complete refund. The camera was great while it lasted! Got about 100 good shots out of it. Will NEVER consider another Minolta digicam after this experience and can't recommend the Z3 to anyone. Careful out there!:(

KueH Oct 6, 2004 10:26 PM

I had a problem with uploading on a friend's computer. It turned out to be a problem with the USB hub he had. When directly connected to the computer, transfers were fine.

I don't doubt other cameras have had failures as well.

neomagic Oct 7, 2004 2:41 AM

So you're not ever going to buy Minolta again in your whole life, because you got one bad unit, right? And you want to warn the whole world so they won't make the same mistake?

My Z3 was bad, too. I checked on the web, no one else seemed to have this particular problem. I returned it, got a new one and am happy with it. Now I'm enjoying a powerful camera at a bargain price.

Maybe you should try to get things in perspective...


All times are GMT -5. The time now is 10:39 PM.