Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Konica Minolta (https://forums.steves-digicams.com/konica-minolta-26/)
-   -   Z3 main LCD all white (https://forums.steves-digicams.com/konica-minolta-26/z3-main-lcd-all-white-138543/)

spatton Mar 19, 2008 6:39 PM

The main LCD just went all white with nothing else visible on the screen. This happened out of no where and for no apparent reason. Thankfully the camera still works if I use the viewfinder, but I much prefer the main LCD. Has anyone else experienced this and if so, is there an easy fix or am I looking at replacing the LCD itself?

Thanks for any input you can provide!



VTphotog Mar 19, 2008 10:12 PM

Is this just when you are shooting, or does it affect the menus as well?

I have heard of problems with the ribbon cable to the LCD on some of these models, so if you can't even see the menus, it could be something like that. If you can see the menus, the problem is likely the camera settings. If set to manual and the shutter speed and aperture are set for low-light shots, the LCD would be washed out in normal lighting.

brian

spatton Mar 20, 2008 12:16 AM

This appears to be an actual LCD issue as the entire screen is pure white. No signs of menu options or any hint of the actual image the camera would normally show on it.

Remember, this issue only affects the main LCD and not the viewfinder. So I would assume that if this were a settings issue that I'd see the same problem in both cases and not just on the main LCD. That's my guess anyway.

You suggestion that it might be the ribbon cable or my guess which is a bad LCD sounds more probable. Sad to say that out of desperation I even tried the WOTS fix which is for an entirely different issue and got zilch. Hey, it was worth a try at least! :)




All times are GMT -5. The time now is 2:14 PM.