Go Back   Steve's Digicams Forums > Post Your Photos > Landscape Photos

Reply
 
Thread Tools Search this Thread
Old Jul 19, 2007, 7:42 AM   #1
Senior Member
 
cmoy's Avatar
 
Join Date: Apr 2006
Posts: 1,712
Default

Had the chance to check out this amazing site on our trip to the Southwest. I was lucky I took this shot because my 10-22mm lens stopped working Any closer I would of missed it.

Thanks for looking!

Chris


cmoy is offline   Reply With Quote
Sponsored Links
Old Jul 19, 2007, 10:10 AM   #2
Senior Member
 
hercules's Avatar
 
Join Date: Mar 2006
Location: Sparta, Greece
Posts: 2,649
Default

Nice shot of that mountain valley,, have you tried a B/W, but what went wrong with your lens;(
hercules is offline   Reply With Quote
Old Jul 19, 2007, 11:50 AM   #3
Senior Member
 
cmoy's Avatar
 
Join Date: Apr 2006
Posts: 1,712
Default

Thanks Hercules! :-) I haven't tried B/W. It's in the back of my mind though :-) I have a few Grand Canyon photos that I want to turn b/W as well.

I dropped the lens fromabout 24" onto a carpet floor. Ever since then I've been getting "error 99" messages when I try to use it. Strange, I only get "error 99" when I shoot outside. The lens and my 20D is out for service right :sad: I'm 99% sure the body has nothing to do with this problem because this only happens to this lens but the service center want to make sure. Hopefully I'll get a call today or tomorrow telling me to take the body back. They can work on the lens as long as it takes butI needthe 20Dfor a baby shower next Saturday :sad:
cmoy is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:14 PM.