Go Back   Steve's Digicams Forums > Post Your Photos > Landscape Photos

Reply
 
Thread Tools Search this Thread
Old Nov 18, 2010, 7:32 AM   #1
Senior Member
 
Join Date: Aug 2006
Location: Tamworth, UK
Posts: 190
Default Tamworth Castle

Taken last weekend when testing my new Z950



Taken on full auto as shot to shot time was not an issue.
__________________
~Sam~

Olympus E420, 17.5-45mm, 14-42mm, 40-150mm, 70-300mm and 25mm lens

Kodak Z950
Thunderchild is offline   Reply With Quote
Sponsored Links
Old Nov 18, 2010, 10:30 AM   #2
Senior Member
 
Walter C's Avatar
 
Join Date: Nov 2004
Location: Huntington Beach, CA USA
Posts: 7,753
Default

A great photo opportunity indeed. I think you should have gotten a bit closer to eliminate the sign (bottom) and the door/gate (bottom right). That would also have put the tree a little more to the left side and revealed a bit more of the castle.
Walter C is offline   Reply With Quote
Old Nov 18, 2010, 8:57 PM   #3
Senior Member
 
hkmp50's Avatar
 
Join Date: Oct 2010
Location: USA
Posts: 1,370
Default

OOOH! another castle pic, I love castles. Too bad they don't build them anymore, well not like this anyway.
Frank
hkmp50 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:56 AM.