Go Back   Steve's Digicams Forums > Post Your Photos > Landscape Photos

Reply
 
Thread Tools Search this Thread
Old Apr 3, 2011, 2:08 PM   #1
Senior Member
 
toshi43's Avatar
 
Join Date: Oct 2005
Location: Vernon BC Canada
Posts: 1,618
Default Still no sunshine.....

We haven't had much sunshine for what feels like weeks, and it's definitely a lot cooler than normal. In spite of the rain, I went for a short hike the other day to get out of the house and took a few pics. I probably shouldn't have because I think I have a cold now...





__________________
Fujifilm FinePix HS10, Fujifilm FinePix HS20 EXR, Pentax E-80 P&S, Sunpak auto383 flash, Optex slave flash, Velbon VGB3 heavy-metal tripod, TechPro TP-242 tripod with B62 ballhead, assorted filters and other bits.
toshi43 is offline   Reply With Quote
Sponsored Links
Old Apr 4, 2011, 2:05 AM   #2
Senior Member
 
banksy's Avatar
 
Join Date: Sep 2009
Location: Western Australia
Posts: 2,144
Default

Looks like your camera might have caught a cold too! Very hilly area around there.
banksy is offline   Reply With Quote
Old Apr 4, 2011, 8:45 AM   #3
spy
Senior Member
 
spy's Avatar
 
Join Date: Dec 2004
Posts: 2,129
Default

I feel your pain :0(... I'm glad to see your getting out though.
spy is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:35 PM.