Go Back   Steve's Digicams Forums > Post Your Photos > Landscape Photos

Reply
 
Thread Tools Search this Thread
Old May 24, 2006, 11:21 PM   #1
Senior Member
 
toshi43's Avatar
 
Join Date: Oct 2005
Location: Vernon BC Canada
Posts: 1,618
Default

I spotted this while walking along a local alley. I posted this shot in the Other Photos forum a while back, but nobody seems to go there.
Attached Images
 
toshi43 is offline   Reply With Quote
Sponsored Links
Old May 25, 2006, 12:44 AM   #2
Senior Member
 
Justin Hancock's Avatar
 
Join Date: Mar 2006
Posts: 272
Default

It's fair to say the picture isn't what I was expecting.
Justin Hancock is offline   Reply With Quote
Old May 25, 2006, 3:16 AM   #3
Senior Member
 
MVASteve's Avatar
 
Join Date: May 2004
Location: Adelaide South Australia
Posts: 793
Default

Is that a Combie relative next to the bug?
MVASteve is offline   Reply With Quote
Old May 27, 2006, 2:21 AM   #4
Senior Member
 
Join Date: Dec 2005
Posts: 105
Default

Brings back memories of scrounging for parts!
Kendb is offline   Reply With Quote
Old May 28, 2006, 12:22 AM   #5
Senior Member
 
Tullio's Avatar
 
Join Date: Jan 2006
Posts: 7,370
Default

Great job capturing the dead bug (and choosing the title!). Yes, Steve, it is a Combie relative on the right. I can tell by the flat front.
Tullio is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:24 AM.