Steve's Digicams Forums

Steve's Digicams Forums (
-   Memory Cards, Microdrives, Card Readers (
-   -   How to format 4 GB (

Imaginx2 Apr 16, 2004 11:12 PM

How to format 4 GB
I formatted the Hitachi 4 GB microdrive in my computer, then in the camera (Nikon 5700). The camera states 'Out of Memory". What is going on?

Klaus DK Apr 17, 2004 2:07 AM

I don't know about the CP5700, but Nikon D100 also has problems with this 4gb card. The solution here is...

Go to My Computer and format with the Disk Managing Tool. Now try and format the CF card with a cluster size of 32k instead of the default 4k, that FAT32 uses.

This could be it!

Imaginx2 Apr 17, 2004 9:31 AM

I am not given an option of cluster size. It automatically put in capacity: 3.81 GB; File System: FAT32; Allocation size: default allocation size. I cannot change this. I have tried. Then it does a quick format.

Klaus DK Apr 17, 2004 11:46 AM

In Windows XP:

right-click on MY COMPUTER in the start menu.

choose MANGAGE

right-click your removable drive and choose FORMAT


Works for me.

(perhaps if you have the XP HOME, it's a bit different...)

Imaginx2 Apr 17, 2004 12:16 PM

I was able to change the settings as you stated, but no change. When I insert the card in my Nikon it reads the card is not formatted. So I format it in the camera. When this process finishes it tells me 'Out of Memory'. The computer tells me the card is healthy and active. According to computer specs on this camera it is compatible. I don't lnow what the problem is. Very pfrustrating when you just shelled out the big $ for this card!

Klaus DK Apr 17, 2004 12:52 PM

I assume, that I don't have to tell you, that you also should try and format in FAT16. As far as I know most Nikon cameras can't read the FAT32!!!!

Why not try first FAT16 in Windows like I mentioned before and then format in camera OR

use the management tool in XP once more and delete the partition, make a new one and format...

have you tried this?

I can't see the problem other than the camera has some problems reading the FAT system...! It's obvious not broke...

Imaginx2 Apr 17, 2004 8:52 PM

I contacted Nikon, they informed me this card is not compatable. I can only use up to a 1 GB microdrive. Thanks for all your help. Much appreciated!

funkriders Apr 20, 2004 4:54 PM

here is your answer to get it to work
here is my post for the minolta. Yours is possibley the same.

I own the Minolta A2 and recently purchased the infamous Creative MuVo2 and yanked the 4 gig card. I formatted it with my computer to FAT32. My camera wouldn't recognize it. I tried everything. I used all sorts of different cluster sizes, I even tried just using FAT. I even tried copying the files from my Microdrive 340mb (which does work). Nothing made the 4 gig card work. I began to think it was bad. I went to the store over lunch and loaded the card in the Sony F-828. It worked just fine. It also worked in the Nikon 8700. I couldn't try the Canon Pro1 or Olympus 8080 because the batteries were dead on them. I formatted the card with the Sony and left feeling bummed that the card wouldn't work in my camera. When I got home, I tried it one last time in a desperate attempt. To my astonishment it worked. I could now format it with my camera. I have shot pictures and dumped them on my hard drive, then formatted with the camera and started over again. It works great. I can get, I think it was, 335 RAW pictures with the 4 gig card. The key is to format with The Sony F-828 to activate usage on the 4 gig hitachi drive for use in the Minolta A2. (Other camera's may fix this too but I can only verify it works by using the Sony). I hope this info helps. Follow by example as we fight the war on price. I don't know why Hitachi thinks they can sell us the same 4 gig stick for $500 that they sell to companies like Creative for $100 or less. What BS. I will play my part in making them pay. Share this info...

Stello May 25, 2007 1:28 PM

Imaginx2 wrote:

I formatted the Hitachi 4 GB microdrive in my computer, then in the camera (Nikon 5700). The camera states 'Out of Memory". What is going on?
I am so annoyed, right now.. I have a Nikon CP5700 as well, and just got a TwinMOS 14X CFC Ultra-X 4GB card for it.

I have that exact same problem! I first formatted the card with the camera, and although it created the Nikon folders, and I can VIEW pictures on the camera just fine (=to test, I dragged some photos from my hard drive to thecard'sDCIM\100NIKON folder, using a card reader), if I try to TAKE photos, it'll just display that red "Out of Memory" text :(

I tried reformatting it a few times, and tried formatting it on a card reader (my XP Home actually doesn't give me options to change file system from FAT32 or allocation size to anything but default), but after the latter attempt, it'll just force me to format it on the camera again.

So, looks like I'm going to have to sell the new card and get a lame 1GB card instead - which is not that much more than my current 512MB card :sad:

All times are GMT -5. The time now is 9:06 PM.