Steve's Digicams Forums

Steve's Digicams Forums (
-   Memory Cards, Microdrives, Card Readers (
-   -   Just returned from vacation and memory card error (

endor12 Sep 24, 2009 5:23 AM

Just returned from vacation and memory card error
I just got home yesterday from an amazing trip to Vietnam. I looked at my pictures on my computer this afternoon and started to download them, and received an error in the middle of the process. My computer prompted to recover bad sectors, I interrupted the process, now my computer will not recognize the memory card and my camera reports a memory card error

I am using a Transcend brand 8GB SDHC card which is 1 year old. I have tried 2 different readers and 2 different laptops. I have an identical card I had pictures on and was able to download the photos with no problem using the same reader/laptop that I was using when I got an error on this card. I see a lot of suggestions about card readers here - both of the card readers I have tried are new, but they are cheap generic readers I got from ebay/Asia. They have worked with identical cards.

I have read through these forums and tried PhotoRec, MediaHeal for Flash, Recuva and some other apps - none of them can see my card. Everything reports that there is no card in the reader.

Does anyone have any ideas? I will be so sad to lose photos from such an amazing trip - I saw them earlier today and know they were there. I definitely will toss the card after I resolve this. I have never had a problem like this before.

I am hoping JimC will weigh in - I have not tried any of your linux recommendations due to my lack of familiarity, but I have been looking through your advice to many others. Many thanks!

TCav Sep 24, 2009 8:43 AM

If all else fails, try

endor12 Sep 24, 2009 10:02 AM

Thanks for the link - holy cow though - $1000! Almost as much as my trip cost. Good to know there is an option, but I had no idea it was so costly.

JimC Sep 24, 2009 10:23 AM

Download the latest SimplyMEPIS 8.0.10 (a free Linux distribution), burn the downloaded .iso file to CD using a tool like Roxio or Deep Burner that knows how to burn the .iso image file to CD. You'll see a "Download Mepis" menu choice on the left side of the main page that has a list of mirrors you can download the ,iso file from. I'd download the 32 bit version of 8.0.10 for better compatibility.

An easy way is to use the download link to the 32 bit .iso file that you'll find in this press release for SimplyMEPIS 8.0.10 at

Here's a direct link to the latest 32 bit .iso file. It's roughly 694MB.


SimplyMEPIS 8.0.10 already has the recovery tools (ddrescue, testdisk, photorec, etc.) we'll want to use on it's Live CD (so you can use them without installing anything to your hard drives).

If you need a program to burn the downloaded .iso file to CD with, try the free version of Deep Burner. It's the second download link on this page:

After you install it and load it, just select the Burn ISO image choice from the menu that pops up when you start it. That will let you browse for the downloaded .iso file and select it so you can burn it to CD.

After burning it to CD, reboot your PC and select the CD as your boot device to load it. It's slow running from CD (versus installing it to a partition on your hard drive), but you can still do what you need running it as a Live CD.

When booting into the CD, press F3 at the boot choice menu to select your desired monitor resolution from a drop down list (it's not an obvious key to press at the boot menu choices, but it's there and will allow you to select the correct monitor resolution in case it doesn't detect your graphics chipset/monitor properly).

Then, use "demo" as the user name and "demo" as the password (without using quotes around them) to load the desktop.

After your desktop loads, open a terminal window (you'll find a choice for Terminal Program/Konsole in the menus). Then, insert your SD card into your card reader and type this, making sure to press the Enter key after each line (entering "root" without the quotes as the password when prompted after typing su and pressing enter).

fdisk -l

You'll find Firefox in the menus so you can copy and paste what you see from those commands into a forum post here. This 4 page quick start guide may help, too. Use the tabs you'll see at the top to switch between pages (the second page under "The First Look" tab shows you the menu choices for booting into the desktop from a live cd).

After you boot into the CD, you'll see a more detailed user guide on the desktop. What I'll probably want you to try is using gnu ddrescue to make an image (exact sector by sector copy) of the card as a first step. Then, depending on what we get, we can run Photorec against that image file, since you won't have the hard read errors trying to recover something from a physical drive that way.

But, I'll need you to paste the results you get from the above commands into a post here so we'll know how to reference your devices and I can give you the correct syntax.

endor12 Sep 24, 2009 11:52 AM

Jim, many many thanks. I think I have done this correctly. Here is what I got:


mepis1:/home/demo# fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd8ba9f9c

Device Boot Start End Blocks Id System
/dev/sda1 1 14402 115682300 7 HPFS/NTFS
/dev/sda2 * 14402 14594 1536000 7 HPFS/NTFS

Disk /dev/sdb: 8068 MB, 8068268032 bytes
233 heads, 20 sectors/track, 3381 cylinders
Units = cylinders of 4660 * 512 = 2385920 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdb1 2 3382 7875072 b W95 FAT32
mepis1:/home/demo# mount
tmpfs on /linux/lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
rootfs on / type rootfs (rw)
/dev/scd0 on /cdrom type iso9660 (ro)
/dev/loop0 on /linux type squashfs (ro)
/ramdisk on /ramdisk type tmpfs (rw,size=2491672k,nr_inodes=221672,mode=755)
/ramdisk on /home type tmpfs (rw,size=2491672k,nr_inodes=221672,mode=755)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
Does that mean anything to you? Again, I really appreciate the help.

JimC Sep 24, 2009 4:31 PM

Sorry for the delay. I was out for a while this afternoon.

Yes. That looks good (it's seeing your 8GB Card as /dev/sdb).

Please do this from a console (using root as the password when prompted). Just copy and paste this into a console if desired:

mount -t ntfs-3g /dev/sda1 /mnt/sda1
cd /mnt/sda1
ddrescue /dev/sdb sd1.img sd1.log
photorec sd1.img

JimC Sep 24, 2009 4:34 PM

Basically, that will mount your Windows NTFS partition (sda1) and navigate to it (so that you'll have a place to save the contents of your SD Card), and use ddrescue to create an image file (exact copy) of your secure digital card named sd1.img. Then, it will run photorec against the image file created. Let me know what you see for output when you use those commands.

endor12 Sep 25, 2009 10:02 AM

Thanks Jim. Here is the response I got:


[email protected]:~$ su
mepis1:/home/demo# mount -t ntfs-3g /dev/sda1 /mnt/sda1
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?
mepis1:/home/demo# mount -t ntfs-3g /dev/sda1 /mnt/sda1
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?
mepis1:/home/demo# cd /mnt/sda1
bash: cd: /mnt/sda1: No such file or directory
mepis1:/home/demo# ddrescue /dev/sdb sd1.img sd1.log

Press Ctrl-C to interrupt
Initial status (read from logfile)
rescued: 0 B, errsize: 0 B, errors: 0
Current status
rescued: 6537 kB, errsize: 8061 MB, current rate: 0 B/s
ipos: 8068 MB, errors: 15868580, average rate: 69544 B/s
opos: 8068 MB

Did that work right?

JimC Sep 25, 2009 10:13 AM

No. It failed to mount your NTFS partition, failed to change directories to where it can save your files, etc.. It looks like I should have told you to use /sda2 instead of /sda1.

Let's try this first:

mkdir /mnt/sda2
mount -t ntfs-3g /dev/sda2 /mnt/sda2
cd /mnt/sda2

Then, copy and paste what you see and we'll go from there. You may get an error after the mkdir command (the folder is probably already there). But, that won't hurt anything. We need to make sure your NTFS partition is mounted and you've changed directories to it.

If it looks like the drive mounted OK, and you changed to the correct folder, then we'll repeat this part:

ddrescue /dev/sdb sd1.img sd1.log

Note that the ddresuce command was copying the sd card. But, you were not storing it anywhere except for RAM. That copy had a lot of read errors, so we may need to make multiple passes to get more data.

endor12 Sep 25, 2009 10:19 AM

This looks better.


mepis1:/home/demo# su
mepis1:/home/demo# mkdir /mnt/sda2
mkdir: cannot create directory `/mnt/sda2': File exists
mepis1:/home/demo# mount -t ntfs-3g /dev/sda2 /mnt/sda2
mepis1:/home/demo# cd /mnt/sda2

All times are GMT -5. The time now is 1:06 AM.