Steve's Digicams Forums

Steve's Digicams Forums (
-   Memory Cards, Microdrives, Card Readers (
-   -   Smartmedia "card error" message (

pca Feb 5, 2003 4:13 PM

Smartmedia "card error" message
I've been searching around the net and have seen many Olympus owners complaining of this error and saw a thread here too, but I have a Fuji camera and it's happening to me.

For some reason this just started and I think it must be an XP problem because I did do a windows update recently.

What happens is after I upload pics using a usb reader, then place the card back in my camera I get a "card error" message. I cannot format the card in my camera because my camera doesn't read it.

I did not format the card in the usb reader. Since then I have tried 4 more smartmedia cards that were working just fine. Then after I simply upload pics in either of 2 usb readers, then place the card back in my camera I get that message and the cards are useless. But they still work fine in the usb adapters! :shock:

What the heck? I have one card left and if I upload the pics from my cameras usb cord the card stays working. So why is simply uploading pics from a usb adapter making the cards no good to my camera, and all of a sudden?

I've seen some say to use a utility to format them and that might work. I tried formatting them in windows but that didn't do anything to solve this problem. I've heard some mention a utility called smprep.exe, but I cannot find it.

Any ideas what to do to save the cards?


gibsonpd3620 Feb 5, 2003 5:32 PM

I think that smprep.exe came with my card reader. I will look at home and see if I have the file.

pca Feb 7, 2003 7:02 AM

Did you find it by chance? I could sure use it to try and save these cards.

And still I'd like to find out why this is happening. It has to be something with XP, or usb drivers.

lg Feb 7, 2003 9:34 AM

I have XP too, but I don't think that is the problem. I had this same thing happen to me, and my remedy was to get Olympus to replace the card. Comparing the properties of the defective card to an identical working card showed differences in cluster size and available free space. For that reason, the only thing I can think of is that the card may have accidentally been formatted in a card reader at work. I'm not sure if this is the solution, but what I have been doing since I got the card replaced is ensuring that the only place I format cards now is in my camera. I know this isn't much help, but I'm afraid it's all I have to offer.

voxmagna Feb 7, 2003 6:50 PM

If it's 'moving' files off the card you're doing as opposed to 'copy' then by the very nature of deleting a file afterwards with your pc you are engaging with the cards format - whether the card is in the cam or a reader. Don't know how your OS likes FAT12. and the special Oly Pano format header.

If it's Smartmedia you are using, then put a write protect tab on it as nothing in a reader (or the cam during COPY upload) will write to it, then delete off the cam not with the pc.

If you have one good card left, use WinHex.exe to take an image of it, keep on your HD, and compare it with a bad one, if the format structure is different use WinHex.exe to copy the good format (with cam files if they're still there) on to the old card. Then look at why your pc is changing the card's format. If it's SM with a tab on you'll get a disc write error message at the point the card is being written back to. Cheers - VOX

pca Feb 7, 2003 10:26 PM

Guys, I am not formatting or deleting anything while the card is in the usb reader. After it copies the pics I remove the media, the pics and all files are still on it. I only format or delete while the media is in the camera.

Where do I find "WinHex.exe". I can sure try that.

Thank you for your replies. :)

voxmagna Feb 14, 2003 6:58 AM

Sorry about the delay. Start here:

digcamfan Feb 14, 2003 1:19 PM

Hi PCA...

Sorry about your difficulties w/smart media.

Sounds like you are doing "nothing wrong".

Btw, I have 128 Smartmedia that is read
on Win ME and Win XP via PCMIA card.

Never had a problem. Brand is Sandisk.

You have not indicated the brand of media.
Perhaps quality control is the culprit.

You might (if you can), look at all files and
folders on a new 128 MB card. Then compare
files and folders in the to the "problem"
smartmedia card.
Then edit copy paste folders and files on
a "good" card to a folder on your hard drive.
Then delete the files and folders on "problem"
smart media (presuming no pics on it!)
Then edit copy edit paste the files and folders
from your hard drive folder to your "problem"
smart media.

Gooda lucka toa you (as my late grandmother would say :) ).

gibsonpd3620 Feb 14, 2003 2:36 PM

I may not be the fastes but I have found smprep.exe filte. Email me if you need the file

[email protected]

voxmagna Feb 15, 2003 4:26 AM

Gib...Thanks for your help. After some research on your file, I found smprep only recognises SCM readers (e.g Dazzle 6-in-1). VOX

All times are GMT -5. The time now is 10:24 AM.