Go Back   Steve's Digicams Forums >

Reply
 
LinkBack Thread Tools Search this Thread
Old Oct 25, 2010, 2:52 PM   #1
Junior Member
 
m00x's Avatar
 
Join Date: Oct 2010
Posts: 2
Default Sony M2 Card lost its file system

its a 5 months old M2 4 GB card.

It was working fine. Yesterday I removed it from the cell phone, inserted it into a card reader, copied some songs to my PC, removed it from the reader and put it back into the cell phone , wah ! it couldnt be detected !! Then I put it back into the card reader, it sayd: drive is not formatted, do you want to format !

What the heck?? I tried all other softwares, Only Stellar Phoenix Photo Recovery 3.5 demo version could see the files and videos. What other ways ???
m00x is offline   Reply With Quote
Sponsored Links
Old Nov 14, 2010, 11:05 AM   #2
Administrator
 
JimC's Avatar
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Chances are, you removed the card from your card reader before all disk writes were completed.

For example, if you wrote anything to the card at the time you were copying songs to your PC (and deleting files like you'd do when moving them, or cutting and pasting them, are writing to the card), and didn't use the "Safely Remove" icon in your system tray, you may have removed it before all writes in the operating system's disk cache were finished writing to it, resulting in a corrupted file system. Note that you can also "right click" on a card under "My Computer" and use the Eject menu choice to do the same thing (make sure all writes are flushed to it and unmount the file system so that it can be safely removed).
JimC is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 5:40 PM.