Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Reply
 
Thread Tools Search this Thread
Old Nov 27, 2006, 9:28 AM   #1
Junior Member
 
Join Date: Nov 2006
Posts: 2
Default

Hello my card was working fine. But now I formated the drive and I get unable to use the card. Any help?

I tried formating the card on my computer with no luck not even my computer will read it. I hope I dont have to buy another card thx.
Raul is offline   Reply With Quote
Sponsored Links
Old Nov 29, 2006, 10:45 PM   #2
Junior Member
 
Join Date: Nov 2006
Posts: 2
Default

Hmm So no one can help me with this question?
Raul is offline   Reply With Quote
Old Nov 30, 2006, 1:23 AM   #3
Administrator
 
steve's Avatar
 
Join Date: Jun 2002
Posts: 2,535
Default

If you can't get the card to format using a card reader and PC it is probably defective. I'd sure talk to the manufacturer and see if they'll fix or replace it.
steve is offline   Reply With Quote
Old Dec 1, 2006, 8:20 AM   #4
Senior Member
 
Join Date: Aug 2002
Posts: 851
Default

It is possible that the partition has been damaged or deleted. Try to repartition the card using a partition manager. If this does not work, then the card may be defective, so I would try to get it replaced/exchanged.
amazingthailand is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:53 PM.