Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Reply
 
Thread Tools Search this Thread
Old Jul 17, 2003, 8:09 PM   #1
Junior Member
 
Join Date: Jul 2003
Posts: 3
Default Problem using ImageMate SDDR-75

Okay i'm a newbie in digital photo and i just got a SanDisk ImageMate to read my CF card. I know the device can run perfectly because some friend of mine was able to use it on my computer and the configuration hasn't been changed since. (BTW i'm running XP)

the problem is that when i insert my card in the reader, nothing at all happens. the green light doesn't light up or anything, even if the device is obviously powered. can someone help me?
Were We Brave? is offline   Reply With Quote
Sponsored Links
Old Jul 17, 2003, 9:02 PM   #2
Senior Member
 
Join Date: Dec 2002
Posts: 430
Default

Perhaps somewhere along the line, (you or someone) told XP to 'Stop removable device...xx.' by clicking on that funky little icon that appears in the system tray when you plug in USB device.

While this is a good (necessary) practice when you intend to physically unplug/detatch the add-on drive, it is irreversable unless you actually unplug and replug the drive (in this case, card reader).

. . . At least that is the way my Sandisk USB reader works with my Win2K system.
jawz is offline   Reply With Quote
Old Jul 17, 2003, 9:04 PM   #3
Junior Member
 
Join Date: Jul 2003
Posts: 3
Default

believe me, i checked everything and the device is supposed to be activated.
Were We Brave? is offline   Reply With Quote
Old Jul 17, 2003, 9:12 PM   #4
Senior Member
 
cope's Avatar
 
Join Date: Jun 2003
Posts: 718
Default

Try uninstalling the card and reinstalling it. Sandisk should have customer support available also.
cope is offline   Reply With Quote
Old Jul 17, 2003, 9:15 PM   #5
Junior Member
 
Join Date: Jul 2003
Posts: 3
Default

i tried it and it didn't change a thing. besides, sandisk has very little support, the manual was only 10 pages long, even though theses pages were so easy to understand but still i can't make it work
Were We Brave? is offline   Reply With Quote
Old Jul 18, 2003, 3:14 AM   #6
Member
 
Join Date: Jan 2003
Posts: 39
Default

I also have the SDDR-75 and it works fine with XP.

You don't need to install any software with XP, it uses the winXP mass storage drivers.

If it doesn't work you either need to make sure that the device does in fact work (try it on another computer) or that your USB port is still OK - look under system devices.
Jola is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:23 PM.