Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Reply
 
Thread Tools Search this Thread
Old Oct 13, 2007, 11:38 AM   #1
Junior Member
 
Join Date: Oct 2007
Posts: 12
Default

I have a Kodak Z612 camera. I also have 5 SD cards. (2) 1gig Kodaks by Lexar, (2) 1gig Lexar, and (1) 2 gig Kingston. None of them are fast ones, basically they were all very cheep$$$. On a recent trip to Florida the camera, at random times, said the card could not be read and needed formating. Panic started to set in when I thought I was going to loose hundreds of pictures. The week we spent in Florida was painfully hot and humid and the camera with all the disks sometimes spent time in a very hot vehicle. At times the camera would work fine and read any one of the cards and other times it would not read any. When I got home I promptly put the cards in my computer reader and they all worked fine and was able to upload all 680+ pics and videos. From then forward the camera (or cards) keep giving me the same random problems. Sometimes the cards can be read sometimes not. If you take the camera's advice and try to format it, it comes back with a message that it cannot format the card. If I put the same card in my computer reader it will read it usually, but sometimes not. And the same cards almost always work in my printer card reader. So the question is, is the problem with my camera or all of my cards? I even went so far as to send the camera back to Kodak to be checked (it's still under warranty) but no changes, it still sometimes will not read the cards. One thing I have done in the past is not pay attention to the flashing light on the camera telling you it's still reading to the card when you shut it off. So that may have done some damage. I've been a (film) photographer for over 30 years, this is my first digital. Any help is appreciated. As a last resort I plan to purchase one more SD card. One of the much faster Lexar pro type just to see if a brand new one (and faster one) will work without issues.

P.S. I have reformated them on somewhat of a regular basis. If the camera will not format them I use my computer to do it using the FAT option.
dj1111 is offline   Reply With Quote
Sponsored Links
Old Oct 13, 2007, 12:47 PM   #2
Senior Member
 
TCav's Avatar
 
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,544
Default

Somethingthatthe camera/cards might have experienced in Florida is extreme humitiy for a long period. Humidity can cause the electrical contacts to oxidize, which decreases their ability to make good electrical connections.

Perhaps you could clean the electrical contacts on your SD cards. The best way to do this is with a simple pencil eraser. I recommend you get one of those brick erasers like this ...



... or one of those pocketable erasers like this ...



Just swipe it along each electrical contact a few times, and be sure to clear away any erasures that might be left behind.

Of course, just to make sure, you could see what happens when you use a new card.
TCav is online now   Reply With Quote
Old Oct 31, 2007, 8:42 PM   #3
Junior Member
 
Join Date: Oct 2007
Posts: 12
Default

Sorry it took so long to reply. I did what you suggested and it seems to work for a while. I also purchased a new Lexar card that included a free download of their Image Rescue Software. Used it on the cards that the camera was having trouble with and they checked out fine. I really think it is the camera. It's still under warranty and I've already sent it in twice for repairs. Now tonight it started telling me my cards needed formatting again then the camera started responding real slow. Snap a picture and it wouldn't actually take it until 10 seconds later. Push the menu button and it wouldn't go to it until 10~15 seconds later. I've emailed Kodak support 3 times now and they have not answered back. So much for their award winning customer satisfaction. Kodak cameras generally get good reviews, that's why I bought the thing. I have asked them to simply replace it with a new one and they act like they are not listening.
dj1111 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:53 AM.