Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Reply
 
Thread Tools Search this Thread
Old Oct 13, 2003, 5:55 PM   #1
Junior Member
 
Join Date: Oct 2003
Posts: 2
Default XD card error

I tried to format an XD card after pulling it from my card reader. My Olympus C750 says I have a card error and will not format.

Is this card now useless? Is there anything I can do to restore it so it functions?

Thanks
fidalgodan is offline   Reply With Quote
Sponsored Links
Old Oct 14, 2003, 4:00 PM   #2
Senior Member
 
Join Date: Aug 2003
Posts: 259
Default

So you tried to format it with the card reader? and now it won't work in the camera? Or did you try to format first in the camera and it didn't work so you then tried the card reader to format it?

Just trying to get some more information on what you did. I'm not totally sure how to, or what to try to fix your situation as I haven't had an issue with any of the 3 xD cards (16, 256mb Oly, 512mb Fugi) I have...although I formatted all of them in-camera on the c750uz I own. :?

I'm sure a little more detail exactly what you did with the card would help find a solution however.
tkmckay is offline   Reply With Quote
Old Oct 16, 2003, 9:18 AM   #3
Junior Member
 
Join Date: Oct 2003
Posts: 1
Default

I also got a prob with a xD card, my camera says card-error when I try to erase or format the card (have 5 pics on it), can't take more either. Although, I can download the pics I have but not erase them either from the camera or the computer (computer says it has erase them when I try but when I refresh the connection to the camera there are still there!). Problem appeared from one day to another and the only thing I can think of is that I removed the card to check the size of it! Is it useless or is it any trick to blank it so I can re-format it? it is a 128MB Olympus xD card.
Matt
Matt-C50 is offline   Reply With Quote
Old Oct 21, 2003, 2:41 PM   #4
Junior Member
 
Join Date: Oct 2003
Posts: 2
Default xd card woes

I, too have a Olympus 750c and my 256 card is now giving me error messages after using my card reader.
Anybody find a solution yet.
The card will not format in the camera.
freescotland is offline   Reply With Quote
Old Oct 22, 2003, 4:35 PM   #5
Junior Member
 
Join Date: Oct 2003
Posts: 2
Default xD card format fix

This may or may not work for all, but I took my 256 fuji xD card to Best Buy and formatted it without a hitch in a Fuji camera.

It now works fine in my Olympus 750-C

Worth a try for those with this problem.
freescotland is offline   Reply With Quote
Old Jun 10, 2004, 9:48 AM   #6
Junior Member
 
Join Date: Jun 2004
Posts: 1
Default

Based on your posting, I was able to repair my corrupted Olympus xd card by formatting it in a Fuji digital camera. My Olympus would not format the card. Thank you so much for this advice.
babelfish is offline   Reply With Quote
Old Jun 16, 2004, 3:21 AM   #7
Junior Member
 
Join Date: Jun 2004
Posts: 1
Default

I owned an Olympus C5060 and have the same problem on Olympus XD card which refuses to be recognized and formatted by the camera after I copied its contents into my PC hard disk using a card reader. Using the same card reader, I have also copied the contents of the CF card which my camera also uses and everythings works fine and there is no problem when I put back the CF card in the camera.

There seems to be a bug either in the Olympus camera XD card drive hardware or in its software. The Olympus XD card which the camera does not want to recognize is working fine when I use it with the card reader. I can read and transfer image into it using the PC and the card reader/writer. I even checked the XD card for any errors using the Windows scandisk program as stated in Olympus reference manual and the scan results reported no errors in the memory.

Surprisingly, as sugeested by in a separate post, the problem XD card can be reformatted in Fuji digital camera and make it work again in the Olympus camera. I have written Olympus Product support and currently waiting for their reply concerning this problem.
~~~~~~ is offline   Reply With Quote
Old Jun 28, 2004, 10:44 AM   #8
Junior Member
 
Join Date: Jun 2004
Posts: 3
Default

Hi! The following info was posted by me originally on other forum
===============================================
Hi, there

I think everybody at least once heard about corrupted XD cards that are not recognized by camera. The most effective solution as of today is to format such a card in FUJI camera loosing at the same time the ability to shoot in PANORAMA mode. Correct? NO
Please let me know if i'm inventing the wheel, but...

I thought that very logical would be to make a health card's image and to restore it into corrupted media. At that stage a problem to me was to find proper soft, because all of them I knew were not intended to work with removable media. After a short research I found "CompuApps™ OnBelay™" from http://compuapps.com/Products/OnBelay/OnBelay.htm . This thing just did the job finely. Actually it was much harder to me to make the cam to not to recognize the card. I completed the whole procedure of making and restoring the image using all possible combinations of camera and card reader. It really worked.
I'm glad I did it and more than that I'm glad I can share this info with you.
=stream= is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:56 PM.