Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Reply
 
Thread Tools Search this Thread
Old Sep 25, 2009, 9:50 AM   #21
Junior Member
 
Join Date: Sep 2009
Posts: 11
Default

Thanks Jim. I'll keep trying. This is so frustrating, not only because it seems like I won't be able to get to the pictures, but because I thought I did a good job of taking card of the card while I was traveling, and I'm not sure how I could alter my behavior in the future to make sure this doesn't happen again.

I really appreciate your help.
endor12 is offline   Reply With Quote
Old Sep 25, 2009, 9:58 AM   #22
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Cards fail from time to time. I'd keep trying to get a good copy of it. I've seen them when they were in pretty bad shape and managed to get data from them. See my posts on this page of a thread where i managed to get a "good enough" copy of a card that didn't want to be recognized at all much of the time:

http://forums.steves-digicams.com/me...ialised-3.html

I've seen hopeless cards, too (nothing would allow you to copy them). But, since it is seeing the card, and able to get a little ways into it before quiting, I'd keep trying and see what you get.

Another technique I've had some luck with is writing a new MBR (Master Boot Record) to a failing card. I suspect that wear leveling algorithms may be coming into play and allowing you to get more from one that way if an error is in the partition table section.

If you can't get anything more from it and want to risk that, we can try using testdisk to write a new MBR (first 512 bytes on the card) and see if that helps anything. Let me know if you make any progress in getting a copy before we go that route though.
JimC is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:32 AM.