Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Reply
 
Thread Tools Search this Thread
Old Mar 29, 2004, 11:39 AM   #1
Junior Member
 
Join Date: Feb 2004
Posts: 20
Default Did I Kill the CF Card...

... or did it just die?

About a month ago I got a Canon A80 and 2x256mb Lexar CF cards. I have been using just one of the cards for over 1000 shots and decided I shouls probably try the other to make sure it worked OK. I put it in took a few captures ... NO problem. Popped the CF card into the card reader on my PC... moved the pics to my hardrive and put the CF card back in the camera.
THEN the camera doesnt turn on. I press the button 2 or 3 times and the power light comes on BUT nothing else. I changed batteries... still no help... I changed CF cards and problem fixed.

Now this CF will not open in my carder reader... actually it kinda locks up the PC.

Im not using ANY software to transfer images... just pop the card in and move the images.

Did I do something WRONG or is the card bad??
LynchMOB is offline   Reply With Quote
Sponsored Links
Old Mar 30, 2004, 12:02 AM   #2
Senior Member
 
marokero's Avatar
 
Join Date: Jun 2002
Posts: 769
Default

Did you get a copy of Image Rescue with your Lexar cards? If so, try to diagnosticate the problem CF with IR. If you got version 1 of Image Rescue, upgrade to version 2 free and you'll be able to use any card reader to check out the card, not just Lexar's own jumpshot reader. Good luck!
marokero is offline   Reply With Quote
Old Mar 30, 2004, 7:39 AM   #3
Junior Member
 
Join Date: Feb 2004
Posts: 20
Default

Nope, I didnt get Image Rescue with the CF card. And I have already sent the card back for replacement. Since Im new to all this Im just trying to figure out if I killed the card or it died.... Would Image Rescue tell me if I killed or it failed? Or would have been able to fix the CF card?
LynchMOB is offline   Reply With Quote
Old Mar 30, 2004, 4:25 PM   #4
Senior Member
 
marokero's Avatar
 
Join Date: Jun 2002
Posts: 769
Default

I've never had a Lexar CF fail on me yet (I've been using two, a 320MB for 5 years, a 1GB for 1 year), but I suppose IR would be able to tell you if there was a problem with your CF. I don't think it would be able to repair a card that has been zapped with static or some oher form of physcal damage. Regardless, Lexar has their lifetime warranty on their pro line of CF's and 5-years on their consumer CF's. Hopefully you get a replacement soon
marokero is offline   Reply With Quote
Old Mar 30, 2004, 4:46 PM   #5
Junior Member
 
Join Date: Feb 2004
Posts: 20
Default

Thanks... It was bought at NewEgg and since it was still in NewEggs 30 days warranty they are sending me a new one.
LynchMOB is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:36 PM.