Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Reply
 
Thread Tools Search this Thread
Old Jan 31, 2007, 12:18 AM   #1
Junior Member
 
Join Date: Jan 2007
Posts: 4
Default

i have a SP-350 Olympus every time I try and turn on the camera it just blinks.. like up top it bilnks orange and green and ive tried putting a new battery in. it doesnt on or nothing.
samihassan is offline   Reply With Quote
Sponsored Links
Old Jan 31, 2007, 2:13 PM   #2
Senior Member
 
Join Date: Dec 2002
Posts: 5,803
Default

Sounds like you should be returning it to me....

Eric
eric s is offline   Reply With Quote
Old Jan 31, 2007, 9:35 PM   #3
Senior Member
 
TCav's Avatar
 
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,571
Default

I agree. I think you should return it to Eric. :-)
TCav is offline   Reply With Quote
Old Feb 10, 2007, 10:43 PM   #4
Guest
 
Posts: n/a
Default

Is it new? If so, take it back where you got it for a new one. If it's still under warranty, contact Olympus through their site & have them fix or replace it for free. If not, send it to Eric to fix it....8)
  Reply With Quote
Old Feb 11, 2007, 12:14 PM   #5
Senior Member
 
Join Date: Aug 2006
Posts: 822
Default

I believe that model has a serious battery problem.

Users suggest you almost have to use a CR-V3 rechargable. NiMH won't work. There's supposedly a firmware update to adress this, but some people have some complaints even after the update.

http://www.dpreview.com/reviews/read...;opinion=30848

Those who use the CR-V3s seem to like the camera. It seems to me that, if they had just given that model a powerful lithium ion rechargeable to begin with, it might have been a very competitive model, and would probably sell for at least $150 more.

If you really want the features on that you can't get elsewhere at the price, then try a CR-V3. If you're otherwise not that attached to the design and features, return it and try something else.

kenbalbari is offline   Reply With Quote
Old Feb 11, 2007, 2:20 PM   #6
Senior Member
 
TCav's Avatar
 
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,571
Default

Kalypso wrote:
Quote:
Is it new? If so, take it back where you got it for a new one. If it's still under warranty, contact Olympus through their site & have them fix or replace it for free. If not, send it to Eric to fix it....8)
Hey. Eric offered, so that would be my first choice.:blah:
TCav is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:09 AM.