Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Reply
 
Thread Tools Search this Thread
Old Dec 16, 2010, 2:45 PM   #1
Senior Member
 
russellsnr2's Avatar
 
Join Date: Apr 2004
Posts: 189
Default Canon 70-200mm F4L and a Canon lens collar

HI, OK I have just purchased a Canon 70-200mm F4L and a Canon lens collar my problem is I use a battery grip (Canon) on my 40D and this seems to stop me attaching the lens to the tripod via the lens collar I am using a Manfrotto 484RC2 tripod head is there something else I need to get this to work please.
Thanks
Russ.
russellsnr2 is offline   Reply With Quote
Sponsored Links
Old Dec 16, 2010, 3:26 PM   #2
Moderator
 
Join Date: Aug 2004
Posts: 8,529
Default

Russ - something doesn't sound right. The head should have a quick release plate that screws into the collar. Does that plate attach OK? Then popping the whole unit on the tripod should not be affected by the presence of the battery grip. And the collar should be designed such that it cannot be mounted backwards on the lens (i.e the bottom of the "L" plate of the collar should go down the barrel of the lens away from the camera body.
JohnG is offline   Reply With Quote
Old Dec 17, 2010, 2:31 AM   #3
Senior Member
 
russellsnr2's Avatar
 
Join Date: Apr 2004
Posts: 189
Default

Hi, Thank you, problem solved. I did not realise that the plate could be attached in two directions so turning it to the side (two arrows on the underside of the plate show direction to fit) rectified my problem, it was the release latch on the rear that stopped the the grip from lowering onto the head.
Thanks Again.
russellsnr2 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:37 PM.