Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Reply
 
Thread Tools Search this Thread
Old Jan 10, 2011, 8:08 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 1
Default Dust on Sensor of Panasonic DMC-ZR1

I have a Panasonic DMC-ZR1 which has very recently started showing 'spots' on all pictures. These spots are apparently caused by dust on the sensor. Panasonic's web site description on their 'FAQ' exactly matches what I'm seeing, but unfortunately doesn't offer any solution.
Is it possible to get the sensor cleaned, or do I just abandon the camera?
I've always used Canon cameras up to this latest purchase and have had no problem with dust, even with my DSLR camera.
Any help would be much appreciated.
MikeDU is offline   Reply With Quote
Sponsored Links
Old Jan 11, 2011, 1:52 AM   #2
Senior Member
 
TCav's Avatar
 
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,544
Default

Contact Panasonic Customer Service about cleaning the sensor. Alternatively, you could contact Precision Camera.
__________________
  • The lens is the thing.
  • 'Full Frame' is the new 'Medium Format'.
  • "One good test is worth a thousand expert opinions." - Tex Johnston, Boeing 707 test pilot.
TCav is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:52 AM.