Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Reply
 
Thread Tools Search this Thread
Old Sep 13, 2011, 3:30 PM   #1
Junior Member
 
Join Date: Sep 2011
Posts: 2
Default Panasonic Lumix DMC-TS10 controls wont respond

Hello.

My Lumix turns on but none of the controls will respond. No zoom, no menu, sometimes the button taking photos works. Otherwise nothing.

Brand new - second time using it.

The included CD did not work with my Mac for installing any software. Connected the camera to my Mac Mini no problem, got my images. I turned off the camera then disconnected. Warning said it wasn't properly removed. I used the camera a second time - everything is fine. Connect to the Mac again, get my images. This time I eject the camera from my desktop before turning off. Now it no longer functions. Lots of things lit up in the camera display, but no response.

Can't connect to my computer either because the button okaying the connection wont respond.

First problem I've ever had with a camera.
Any ideas? or is this just a piece of junk?

Thank you
FilmSpaz is offline   Reply With Quote
Sponsored Links
Old Sep 13, 2011, 7:13 PM   #2
Senior Member
 
VTphotog's Avatar
 
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,214
Default

Don't know the camera, so all I can give is generic advice. Take out the batteries, leave them out overnight, while they are charging. Look at your manual and find where you can reset everything to factory defaults, and do this after you replace the batteries. (assuming you can now access the menu) If this doesn't work, try the forum specific to your camera for better advice.

brian
VTphotog is offline   Reply With Quote
Old Sep 26, 2011, 3:12 PM   #3
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,734
Default

Hi- not a specific point to your problem- though I would highly recommend getting a card reader and just popping that into your system. Computers and such like have been known to cause camera problems when connecting via USB hub,though in your case I hope VTphotog's advice works for you!
SIMON40 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:55 AM.