Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Thread Tools Search this Thread
Old Jul 18, 2017, 11:46 AM   #1
Junior Member
Join Date: Dec 2009
Posts: 14
Default What's wrong with my digital camera?

Is this discoloration (neon pinks, blues, and greens) due to damage to my lens, processor, .....? Please see attachment

This started happening recently but I don't know what caused it. I reset the camera to factory specs but it didn't make a difference.

Any ideas?

Attached Images
testers is offline   Reply With Quote
Sponsored Links
Old Jul 21, 2017, 5:46 PM   #2
Senior Member
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,935

G'day mate

I have seen this once before in a camera that had been very wet on one occasion and the moisture had encroached into the works. If this is the case with you, I cannot see any 'cheap' way out beyond buying another camera to replace this one

Hope this helps
Has Lumix mirrorless & superzoom cameras and loves their amazing capabilities
Spends 8-9 months each year travelling Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote
Old Jul 31, 2017, 7:25 AM   #3
Senior Member
Join Date: Oct 2014
Location: wales
Posts: 138

Obviously not the lens or it would be the same every time !

Looks like it may have got wet at some time, and the electronics, are affected, looks like a new camera time
Nikon D5, D4s, 810, Nikkor lenses 14-24, 70-200 f2.8, 80-400 "Nano version", 24-120 f4, SB910s Lee filter system, Siggy 15mm, Siggy 150-600 Sport, Gitzo Tripods, many GoPros

JR1 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:22 AM.