Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Reply
 
Thread Tools Search this Thread
Old Oct 9, 2003, 3:16 PM   #11
Junior Member
 
Join Date: Oct 2003
Posts: 0
Default

I recently upgraded purchased the s414 to replace my HP 850. The Hp served me well, as the first digital Ive owned. It allowed me to take some great tele shots. The camera developed a problem where the lens "froze" in the extended position, requiring me to power down the unit, or even remove the batteries in order to re-set the camera. Sams Club refunded the money for the purchase, so I decided to try the S414 while deciding on a DSL type to purchase this winter.
azupsman1 is offline   Reply With Quote
Old Oct 9, 2003, 3:17 PM   #12
Junior Member
 
Join Date: Oct 2003
Posts: 0
Default

I recently upgraded purchased the s414 to replace my HP 850. The Hp served me well, as the first digital Ive owned. It allowed me to take some great tele shots. The camera developed a problem where the lens "froze" in the extended position, requiring me to power down the unit, or even remove the batteries in order to re-set the camera. Sams Club refunded the money for the purchase, so I decided to try the S414 while deciding on a DSL type to purchase this winter.
azupsman1 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:39 AM.