Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Nikon dSLR (https://forums.steves-digicams.com/nikon-dslr-57/)
-   -   Buyer Beware - D600 Shutter (https://forums.steves-digicams.com/nikon-dslr-57/buyer-beware-d600-shutter-209119/)

Franko170 May 9, 2014 10:14 PM

My D600 is being shipped back to me, Nikon Tech said they did another reset (did one on the phone with tech the first time and it didn't help) and now they say the shutter is fine; we shall see as I'll test it as soon as I get it back.

I logged in at Nikon website service/support and asked a couple questions. If shutter is the same as previous, a 610 shutter or some other variation and if the specs would be the same - fps etc. I received an email earlier this evening saying it is the same shutter with 'improved parts' to help prevent the problem from reoccurring.

MarceloLI May 21, 2014 8:16 PM

Today in the morning I dropped at Nikon Melville my D600, I was planning to do it since the Service Advisory came out but I was traveling all the past two months.

The technician was very courteous and he explained that is not oil on the sensor the problem with the D600 but electromagnetic dust ( i have my doubts) he stated they will fix the issue and I will have back my camera in 6-8 days.

Lets see what happen and I hope I have the same luck of Zig and receive a check :-)

Marcelo

Scouse May 24, 2014 11:32 AM

Quote:

Originally Posted by MarceloLI (Post 1374344)
Today in the morning I dropped at Nikon Melville my D600, I was planning to do it since the Service Advisory came out but I was traveling all the past two months.

The technician was very courteous and he explained that is not oil on the sensor the problem with the D600 but electromagnetic dust ( i have my doubts) he stated they will fix the issue and I will have back my camera in 6-8 days.

Lets see what happen and I hope I have the same luck of Zig and receive a check :-)

Marcelo

Perhaps you should mention that dust tends to stick to oil...:)

My friend Terry suggested (strongly) that a new 610 would be acceptable but they fixed his a second time and sent it back. Seems to be working fine, right now!

Franko170 May 28, 2014 1:05 AM

I'm going to put some mileage on my D600 since its shutter replacement and cleanings. I did some test shots within the first few dozen frames - aimed at sky at f16. There seemed to be two faint spots - not just teeny specks, round spots - like they were never completely cleaned off from previous cleanings by Nikon and by Best Buy Geek Squad. In a couple months I will shoot some f16 at the sky again and see if the problem is 'symptomatic' - not just if there is dust/oil, but if it comes back in the same upper left corner where it was before. I have been very careful about changing lenses. If when I look there is not much difference, then fine, the D600 is a great camera and I will on occasion give it a cleaning. Maybe pick up one of those sensor gel sticks that came out. BUT if it has dust/oil in the upper left where it was before, I would consider that as evidence that the problem remains. Then I will start talking about where's my 610.

zig-123 Jul 30, 2014 8:33 PM

Another Service Advisory
 
Received another Nikon Service Advisory regarding the problems associated with the D600.
I am, again, (3rd time) returning this body to Nikon for repair or hopefully replacement.

This is the most frustrating experience I've ever had with a digital camera,
regardless of the brand.

I sure hope they do what's right this time.

Zig

Franko170 Aug 9, 2014 12:12 AM

U1 is again malfunctioning on my D600. I had to do a full reset last time it happened, and it's back. When using Auto ISO, Setting U1 and U2 to the same settings and shooting at the same scene, the u2 works fine but the U1 won't give me shutter speed I want. Will be making a phone call to Nikon again soon.

In the meantime I'm still getting some great photos with it working around the problems.

Here's a shot I took a few weeks ago with an 85 1.8D set at f/3.2, informal portrait that took about 10 secs.


https://dl.dropboxusercontent.com/u/...378blueafb.jpg

Wingman Aug 9, 2014 10:21 AM

Beautiful image...lighting and texture are A+.

Franko170 Aug 9, 2014 4:09 PM

Thank you Wingman, at a small park in the middle of South Bass Island on Lake Erie - asked subject to have a seat on a dolphin statue, took about 3-4 shots and we moved on.


All times are GMT -5. The time now is 6:23 AM.