Go Back   Steve's Digicams Forums >


Reply
 
LinkBack Thread Tools Search this Thread
Old Jan 24, 2005, 8:57 AM   #1
Member
 
thommas's Avatar
 
Join Date: Jul 2004
Posts: 43
Default

My nikon D70 cannot befound in win2k, which was fine before until a week ago. I usually plug usb cable in and the system finds camera with out any problem.



but yesterday it suddently went wrong and the camera display (which normally shows "PC") now shows nothing. I have formateed and reinstalled windows 2000 and nothing helps.

What else can be wrong and what can I do??
thommas is offline   Reply With Quote
Sponsored Links
Old Feb 7, 2005, 8:03 PM   #2
Junior Member
 
pyropuppy's Avatar
 
Join Date: Feb 2005
Posts: 7
Default

have you tried it on another pc?
have you tried another cable?
pyropuppy is offline   Reply With Quote
Old Feb 8, 2005, 10:42 AM   #3
Senior Member
 
Morris's Avatar
 
Join Date: Mar 2004
Posts: 113
Default

There is a setting in the camera to change the usb mode.

Did you change this setting?
Morris is offline   Reply With Quote
Old Feb 11, 2005, 6:01 AM   #4
kex
Senior Member
 
kex's Avatar
 
Join Date: Jul 2003
Posts: 1,022
Default

I'd recommend getting a card reader for two reasons:

1. the nikon d70 does not support USB 2.0 which is a lot faster than the old USB1.

2. You don't need to connect your camera to the pc every time you took some pictures.

When I have taken some pictures, I take the CF card out of the D70 and put the D70 back into my bag. easy and uncomplicated.
kex is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 8:33 PM.