Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Apr 18, 2007, 5:44 AM   #1
Senior Member
 
snakeman's Avatar
 
Join Date: May 2003
Posts: 181
Default

hey there everyone.
just wanted to check if the Flash SB600/800 ever needs to be taken in for a service...or does it have a certain lifespan...

reason im asking...
a mate of mine shoots with a D70+SB800 flash ...
ive just started shooting with a D80+SB600 flash.

we were shooting for a nightclub on fri night and most of the close up pics with the D70+SB800 came out over exposed while the D80+SB600 came out perfect....same shots....and not just one or two...but almost all of them that we compared...

his SB800 has taken over 10000 pics...
his D70 has taken over 30 000pics...(but has been service every 10 000pics)
this is due to him shooting weddings and tons of em....

any reason why the flashes performned so different?

both of them were in iTTL mode and on auto while we were shooting in Aperture priority.
snakeman is offline   Reply With Quote
Sponsored Links
Old Apr 22, 2007, 2:14 PM   #2
Member
 
wingnut1's Avatar
 
Join Date: May 2005
Posts: 45
Default

What glass were you using? I know that some Sigma lenses tend to overexpose with the SB800. I have the Siggy 10-20 and get this, but I just remember to either stop down more or use the - button on the flash to compensate.
wingnut1 is offline   Reply With Quote
Old Apr 22, 2007, 5:38 PM   #3
Senior Member
 
cope's Avatar
 
Join Date: Jun 2003
Posts: 718
Default

On their website, Nikon recommends servicing, I believe annually.
cope is offline   Reply With Quote
Old Apr 23, 2007, 1:55 AM   #4
Senior Member
 
snakeman's Avatar
 
Join Date: May 2003
Posts: 181
Default

wingnut1 wrote:
Quote:
What glass were you using? I know that some Sigma lenses tend to overexpose with the SB800. I have the Siggy 10-20 and get this, but I just remember to either stop down more or use the - button on the flash to compensate.
hi there.

thanks for the reply.

the sb800 was being used with the nikon 18-70 kit lens that came with the D70....



@cope....thanks...ill be sure to tell him to have it serviced then.

thanks a lot folks.

cheers for now.

Bryce
snakeman is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:34 AM.