Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Jun 30, 2008, 2:52 AM   #1
Junior Member
 
Join Date: Jun 2008
Posts: 1
Default

Hello,

I am new to DSLR photography. I boughta new Nikon D80 camera. I got a few problems in Automatic focus. May be its me (probably got the setting wrong).

My lens is set to AF and have set the body's switch to AF. It doesn't autofocus when I press the shutter release button. It doesnt take a picture. A red light flashes inside the viewfinder. Sometimes F_ _ blinks.

The AF button on the top of D80 camera is not working. No options (AF-A, AF-S, AF-C is not displayed. Few days back it worked and I was able to shoot some pictures)Nothing happens when I press the AF button now. The control panel which would display the AF-A, AF-S, AF-C is blank.

Could some one please help me?

Thanks
Natchi
Natchi is offline   Reply With Quote
Sponsored Links
Old Jun 30, 2008, 7:14 AM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

I'd try remounting your lens. It may not be making a good connection.

JimC is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:14 AM.