Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Oct 18, 2008, 9:55 AM   #1
Junior Member
 
gerreilly's Avatar
 
Join Date: Apr 2006
Posts: 14
Default

Treated myself to a new flash but shock horror it wont work with my Nikon D40X. Ran all the way in to my local camera shop where I purchased and shock horror again this flash wont work with any Nikon dSLR well we tried a D60 and D80 and no joy.
Had to fork out an extra 100 euro for the Nikon SB-600 unit. Anybody else had this problem. Have Nikon incorporated some bug to stop non Nikon flash. :?
gerreilly is offline   Reply With Quote
Sponsored Links
Old Oct 18, 2008, 10:36 AM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Are you sure it's not defective (or that some kind of setting wasn't as needed)?

From what I can see on Sigma's web site, it should fire with your D40x. But, the AF Assist Lamp won't work unless you've got Center Focus set. You'll see a link on this page that goes to a compatibility chart for Nikon Autofocus models:

http://www.sigma-photo.co.jp/english...lash_530st.htm



JimC is offline   Reply With Quote
Old Oct 18, 2008, 12:37 PM   #3
Junior Member
 
gerreilly's Avatar
 
Join Date: Apr 2006
Posts: 14
Default

Thanks Jim for the reply.I am almost sure we tried that plus we also tried out another flash no joy. The Nikon flash is pretty super though.
gerreilly is offline   Reply With Quote
Old Dec 9, 2008, 9:31 PM   #4
Member
 
Join Date: Dec 2008
Posts: 63
Default

should have been a changeable module that fits at the flash shoe actuarly part of the shoe.one for canomn another one for nikon and so on.
scooptdoo is offline   Reply With Quote
Old Dec 11, 2008, 6:10 AM   #5
Senior Member
 
Join Date: May 2005
Posts: 162
Default

I had the same problem with my d80 and sigma flash. It worked great on my d50 but only works with center focus setting on the d80.
BEECEE is offline   Reply With Quote
Old Dec 11, 2008, 6:11 AM   #6
Senior Member
 
Join Date: May 2005
Posts: 162
Default

I had the same problem with my d80 and sigma flash. It worked great on my d50 but only works with center focus setting on the d80.
BEECEE is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:55 AM.