Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Oct 8, 2010, 10:39 AM   #1
Senior Member
 
Join Date: Apr 2004
Posts: 688
Default D300s HELP

i filled a 4g sd card recently on my D300s, an usually after downloading the pics on to the computer, i reformat the card.
as far as i can remember when you reformat a card you will loose all data.
i used that same card in a pentax k20d, and when i turned on the k20 for some reason i hit the play button and low and behold, all the pics from the D300 was there. so i took out the card and placed it back into the d300s hit the play button and the lcd read no images. placed the card back into the k20d and yes all the pics were there.
What is happening here

Dave
T&T
dafiryde is offline   Reply With Quote
Sponsored Links
Old Oct 8, 2010, 11:38 AM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

How did you format the card (using camera menus, windows, etc.)? What file system type were you using (was it FAT32, which is what you want to use for a 4GB SDHC Card)?

Most of the time, a format doesn't actually delete the underlying data. But, it should recreate the FAT (File Allocation Table) for you. So, you should not see any images on the card without using specialized tools.

If you do use a PC to format a card (which I would not recommend doing unless if you a problem with it), make sure to use the Safely Remove or Eject features of your operating system ("right click" on the card under "My Computer" and use the "Eject" choice). That insures that any writes left in the operating system's memory have been flushed to the card before you remove it (so that you don't end up with a corrupted FAT, which sounds like what your problem may be if you're sure you formatted it).

In the case of SDHC cards, I'd probably use this utility if you format it from a PC using a card reader (or if you've formatted it using a PC before, since the format you used may have an issue that's causing your problems). I would not try to use the camera as a card reader. Use a dedicated SDHC card reader instead.

http://www.sdcard.org/consumers/formatter/

But, after using that utility, I'd reformat it with the camera's menu choice for format (with the camera you're going to use it in) prior to using it again. That way, it's formatted just the way the camera expects it, since it's performing the format.

Personally, I always reformat my memory cards using a camera's menu choice for format (not a PC) prior to every reuse.
JimC is offline   Reply With Quote
Old Oct 8, 2010, 12:09 PM   #3
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

BTW, if you did you use the camera's menus to format it, are you sure the SD Card slot was selected as your primary and you didn't have a CF card in it?

IOW, if you had both card types in it, perhaps you formatted the CompactFlash card instead of your SDHC Card, and you're not seeing any images with the Nikon because it's looking at the CF card contents. ;-)
JimC is offline   Reply With Quote
Old Oct 8, 2010, 10:59 PM   #4
Senior Member
 
Join Date: Apr 2004
Posts: 688
Default

Quote:
Originally Posted by JimC View Post
BTW, if you did you use the camera's menus to format it, are you sure the SD Card slot was selected as your primary and you didn't have a CF card in it?

IOW, if you had both card types in it, perhaps you formatted the CompactFlash card instead of your SDHC Card, and you're not seeing any images with the Nikon because it's looking at the CF card contents. ;-)
This has to be the strangest thing ever.
i only format my cards in the camera.
i only have sd cards.
i even formatted the card again in the camera, and still the pics are showing on the k20d lcd screen, it evens shows the shooting info.
and no i have not formatted it in the K20d to see what happens.
i tried the card in a canon s5is, and it says no images.
it seems only the k20d is picking up these so called deleated pics, about 200+, but the video files that were on that card is not there.or the k20d is not reconizing it


Dave
T&T
dafiryde is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:51 AM.