Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Aug 26, 2011, 5:06 PM   #21
Junior Member
 
Join Date: Aug 2011
Posts: 1
Default

Bynx: How did you determine the spots were caused by oil?
Did you have to get a number or something from Nikon for them to accept it for a warranty cleaning?
My D7000 is beginning to show spotting on the right side of images also. (Lens has never been off the camera) Guess I'll be dealing with this too.
rlrlrlrr is offline   Reply With Quote
Old Aug 26, 2011, 8:54 PM   #22
Senior Member
 
Bynx's Avatar
 
Join Date: Jun 2007
Posts: 8,622
Default

I determined it was oil after using a blower and they didnt move. The spots arent dust, or water so oil is left. Then I googled oil on sensor and up came a number of sites talking about the problem. As yet Im not sure how bad the problem is in the longrun. If my camera comes back I will be sure and let everyone know if the servicing was worth it or not. There is a 2 year warranty in Canada on the camera, but this problem will be occurring a long time before that. Like maybe the first couple weeks or month. You will notice the spots if you take pics with small apertures which focuses on the spots more than if the lens is wide open. Also if all the spots are the same size and same round shape and evenness in dark color is a good indication of oil. Also I notice you said your spots were coming up on the right side. Well thats a good indicator that you have the same problem. You can wait a few days until I get my camera back and I let you know what happened or you can send it in right away and get it cleaned.
Bynx is offline   Reply With Quote
Old Sep 4, 2011, 8:36 PM   #23
Senior Member
 
Franko170's Avatar
 
Join Date: Aug 2009
Posts: 303
Default

Had noticed some slight spots on my D90 - looks like oil also from what has been shown here. Mine's far out of warranty though. Not encouraged by what I'm reading here concerning Nikon support.
__________________
Nikon D600, D90, D70, N90s, FM2, Canon S3 1S, Panasonic FZ35; Nikon 18-105 VR, 28-70 2.8 Sigma, 35-70 Nikkor, 70-200 2.8 Sigma, 70-300 4-5.6 Sigma, 85 1.8D Nikkor, 55-300 4-5.6 Nikkor, Sigma 17-50 2.8.
Franko170 is offline   Reply With Quote
Old Sep 5, 2011, 10:24 PM   #24
Senior Member
 
Bynx's Avatar
 
Join Date: Jun 2007
Posts: 8,622
Default

Apparently you get better support if you take the camera in yourself instead of having it shipped UPS/Purolator/FedEx. Its been over a week now and they havent gotten around to fixing it yet.
Bynx is offline   Reply With Quote
Old Sep 12, 2011, 2:47 PM   #25
Junior Member
 
Join Date: Sep 2011
Posts: 6
Default

I’ve had the D7000 about 9 months now, in May I went away and took several hundred photos and found the oil on the sensor.
At this point I went through every photo I had taken and found one or two splatter marks on the first photos, with them multiplying with every photo getting worse as the camera was used, when I took it to the shop there was probably about 30-40 marks.

Took the camera back and was told by the shop it was dust, I politely told the shop manager to look again and he confirmed after that it wasn’t dust so sent the camera back to Nikon for sensor clean.

Got the camera back and the 1st 10-20 pictures where fine, the last 60 or so photos are again showing the oil splatter marks.
Looks like another trip to the shop!

The camera was away at Nikon for about 5 days, however how can I trust this camera now, I'm going away on a months trip of a lifetime to Australia and New Zealand, Im not sure this camera will be joining me .
The Mole is offline   Reply With Quote
Old Sep 12, 2011, 6:54 PM   #26
Senior Member
 
Bynx's Avatar
 
Join Date: Jun 2007
Posts: 8,622
Default

Good timing Mole. I got my D7000 back from Nikon today. Now if they have to clean the sensor what percentage is acceptable. Or should it be clean?

Well got my D7000 back from Nikon today. They had it 2 weeks and this is the results. When you have to clean the sensor is there a percentage which is acceptable or should it be clean?

Bynx is offline   Reply With Quote
Old Sep 14, 2011, 7:38 PM   #27
Senior Member
 
Join Date: Nov 2010
Location: Belize & UK
Posts: 463
Default

Clean is totally clean. Partially clean is dirty and unacceptable, from any brand of camera. The above image shows an unacceptable state. But rather than returning the camera to the manufacturer, why not buy some Sensor Swabs and Eclipse Fluid and clean it yourself? If you clean it thoroughly so that NO marks appear, and shortly after it shows fresh marks that you identify as oil, then I'd say you have a significant problem. I am perhaps lucky that neither of my DSLRs has ever suffered from oil on the sensor, and only the older one has so far even suffered from dust.
__________________
Canon 5D & 7D (both gripped), 24-105L, 100-400L, EF-S 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, A1+10 FD lenses, tripods, lights etc
peterbj7 is offline   Reply With Quote
Old Sep 14, 2011, 8:18 PM   #28
Senior Member
 
Join Date: May 2011
Location: UNITED STATES
Posts: 1,004
Default

Bynx,

I've had my brand new D7000 for about 3 weeks. After I shot about 2 weeks and I tested f22/25 at blue skies, I noticed the splatters on images. Then I ordered the Copper Hill Kit (about $80) and cleaned it myself couples of times. When I cleaned it the first time, it didn't become completely clean however the second time I got it all. Totally cleaned now. I was going to send the camera back to Nikon (under warranty), but I didn't. To summarize, this is a common occurrence at this point and once the amount of lube in this mechanism is gone, it won't come back again. I'd like to suggest that "DIY".

Thanks for sharing your experience. Appreciate it.

Jeff
__________________
http://www.flickr.com/photos/ujefrocnrol/

FZ40 & FinePix J27,28,29
UJEFROCNROL is offline   Reply With Quote
Old Sep 15, 2011, 4:38 AM   #29
Senior Member
 
Join Date: Nov 2010
Location: Belize & UK
Posts: 463
Default

Just how "common an occurrence" is it? I live in a hot climate (where oil would tend to become thinner and more ready to fly around) and have experienced no oil problems, nor so far as I know have friends with a variety of cameras (of several makes). I would have expected mirror lubricant to have been grease, not oil, that would not melt at temperatures generally found in the environment. Liquid oil seems to be quite an unsuitable lubricant.
__________________
Canon 5D & 7D (both gripped), 24-105L, 100-400L, EF-S 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, A1+10 FD lenses, tripods, lights etc
peterbj7 is offline   Reply With Quote
Old Sep 15, 2011, 9:50 AM   #30
Senior Member
 
Bynx's Avatar
 
Join Date: Jun 2007
Posts: 8,622
Default

Ujefrocnrol since the camera is new and under full warranty sending it in and letting Nikon fix the problem seems to make more sense than my fixing it myself and taking the big risk of doing more damage than was already done, thereby making my warranty null and void. There is now a record of the oil spots, and should they increase beyond the one main spot, sending it back to them will be no expense to me. When the time comes that there is no warranty then I will have no hesitation about tackling the problem myself. To anyone having this problem they dont just clean the sensor, they address the source and apparently clean out the excess that was splashing out. Just cleaning the sensor doesnt do that and the problem will continue.
Peterbj7 the problem is apparently common with earlier build of the D7000. The excess oil was not done on later issues. I dont know the serial number range for those with the problem.
Bynx is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:12 PM.