Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Dec 30, 2002, 10:50 AM   #1
Junior Member
 
Join Date: Sep 2002
Posts: 9
Default D100 pixel fault lcd screen

Hi all & a happy new year to everyone

I have just purchased the D100 and think it is totally excellent......but there is (I think this term is right) a hot red pixel on the lcd display? I have had a couple of digicams previous to this and not come across it before.

It does mention at the front of the handbook that this problem can occur and that it is classed as acceptable! I however feel that it is not acceptable on a product costing as much as this!

I cannot contact my supplier until next week due to holidays but wondered what, if any, peoples thoughts were on the forum and whether anyone else has come across this before?

Any advice appreciated,

Rich.
Rikk is offline   Reply With Quote
Sponsored Links
Old Dec 31, 2002, 10:07 AM   #2
Member
 
Join Date: Aug 2002
Posts: 44
Default

I know this Discussion not much join. You can try join, there is lot people about Nikon DSLR:

http://www.robgalbraith.com/cgi-bin/...?ubb=forum&f=1

You can ask them what is your problem LCD. They may know or help than this.
polarbear is offline   Reply With Quote
Old Dec 31, 2002, 2:28 PM   #3
Junior Member
 
Join Date: Sep 2002
Posts: 9
Default

Thanks for the link..........I'll give it a try.

Rich
Rikk is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:13 AM.