Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Oct 30, 2005, 10:32 PM   #1
Member
 
Join Date: Mar 2005
Posts: 63
Default

I just got my D50 TWO DAYS AGO and took some pictures with it, then connected it to my TV with the AV adapter. On connecting it to the TV, I felt a charge in my hand A) connecting it to the TV and B) touching the camera, at the metal part at the base of the lens near where it screws into the camera.

I used it immediately afterwards it seemed fine, though focusing seemed slow (although it was in low light, no flash, and I had the AF assist light turned off).

Today the lens is making slight squeaking noises when zooming in and out (this may be normal - but I dunno) otherwise when focusing on normal objects focusing is still very fast.

Should I be worried about the camera? How could I tell if it's been damaged? Does anybody know if this is likely to be covered by warranty? Have any other Nikon D50 owners experienced this?

Any responses would be appreciated.

JV

PS - I have also posted this thread in the "Newbie Help Forum"
lhtorrie is offline   Reply With Quote
Sponsored Links
Old Oct 31, 2005, 1:36 AM   #2
Senior Member
 
Join Date: Feb 2004
Posts: 108
Default

I haven't had that kind of problems but electrofying camera sounds quite odd though.
If the cameras TV-out can handle the (over)voltage rest of the camera should handle it too,
just keep using the camera and see if any issues beging to emerge.
Shred is offline   Reply With Quote
Old Oct 31, 2005, 8:36 AM   #3
Member
 
Join Date: Mar 2005
Posts: 63
Default

Shred - thanks for your thoughts on this.

I've been playing around with the camera quite a lot today. None of the menus are corrupted and there are no obvious issues. I'll watch it and see how it goes.

I looked in the manual, and it warns of turning off the camera prior to connecting it, and advises removing and reinstalling the battery, resetting the camera after such an episode. I think that as my camera was off, it may have made the difference.

JV
lhtorrie is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:26 PM.