Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Jun 26, 2006, 5:07 PM   #1
Junior Member
 
Join Date: Jun 2006
Posts: 4
Default

hi all. I've had my Nikon D70 for over a year and a half. I picked up my D70 today to doa shoot and found out the autofocusing was slipping ( like a tranmission). I cant frisgure out why. It will how ever focus sometimes. When I take the lens off, and try to use Autofocus, and re- attatch it, itwill work then slip once again. I've also noticed that the camera will appear on even though it is shut off. (messed up isnt it?) Has anyone had these problems before? Im recharging the battery, hoping its one of the "saves". I have a wedding to shoot on the 4th of july and a senior to photograph in a few weeks.:?

thanks for the help
ACDCRCCKER is offline   Reply With Quote
Sponsored Links
Old Jun 26, 2006, 5:35 PM   #2
Senior Member
 
pagerboy's Avatar
 
Join Date: Feb 2005
Location: Canada
Posts: 483
Default

Have you tried another lens?
pagerboy is offline   Reply With Quote
Old Jun 26, 2006, 5:43 PM   #3
Junior Member
 
Join Date: Jun 2006
Posts: 4
Default

yes I have
ACDCRCCKER is offline   Reply With Quote
Old Jun 27, 2006, 1:32 AM   #4
Junior Member
 
Join Date: Jun 2006
Posts: 4
Default

Any Body?
ACDCRCCKER is offline   Reply With Quote
Old Jun 27, 2006, 1:32 AM   #5
Junior Member
 
Join Date: Jun 2006
Posts: 4
Default

Any Body?
ACDCRCCKER is offline   Reply With Quote
Old Jun 27, 2006, 5:11 AM   #6
Senior Member
 
rjseeney's Avatar
 
Join Date: Dec 2004
Location: Taylor Mill, Kentucky
Posts: 2,398
Default

I don't think there are many people here qualified to provide you with diagnostic service. It sounds as if your camera is in need of repair. I certainly wouldn't chance it dying during a wedding. Now would be a good time to invest in (or at least rent) backup equipment if you don't already own a second body.
rjseeney is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:30 PM.