Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Reply
 
Thread Tools Search this Thread
Old Jul 18, 2006, 11:30 PM   #1
Junior Member
 
Join Date: Jul 2006
Posts: 5
Default

all of a sudden my flash stops working. I try everything. I power it off. Press the reset. Everything possible to try and get the flash to work again. But it wont go. It will pop up in Auto-Flash but the flash wont FLASH!

Its a Nikon d50 SLR. the flash was working perfectly too until all of a sudden.

Any ideas on what is going on or what I should do? did the bulb just blow? how can i tell if it is?


I just wanted to get some idea of what it could be before I call Nikon or go to a camera repair store.

ericmai is offline   Reply With Quote
Sponsored Links
Old Jul 19, 2006, 6:16 AM   #2
Junior Member
 
Join Date: Jul 2006
Posts: 2
Default


Hi, you are not alone, the same thing has just happened to my D50 too. I've had it less than two months and the flash has been working fine, but all of a sudden, no more flash.

It pops up but won't fire.

Has this happened to anyone else? Perhaps it's a common problem with the D50?
markvan is offline   Reply With Quote
Old Jul 19, 2006, 7:02 AM   #3
Junior Member
 
Join Date: Jul 2006
Posts: 5
Default

I am hoping that the flashbulb just blew... I will find out today hopefully when I take it to the shop. Ill let you know what it is if I find out.
ericmai is offline   Reply With Quote
Old Jul 19, 2006, 7:32 AM   #4
Senior Member
 
tommysdad's Avatar
 
Join Date: Mar 2005
Posts: 714
Default

Have you tried seeing if the flash will fire in Aperture or Manual modes?

TD
tommysdad is offline   Reply With Quote
Old Jul 19, 2006, 7:51 AM   #5
Senior Member
 
Join Date: Feb 2006
Posts: 172
Default

I certainly can NOT help you here but remember similar posts where even advanced shooters had forgotten they put the camera on a different mode, modes where the camera will not LET the flash fire. Sounds like the above question is more specific. Just passing along that you may have the "oh brother" moment like others if you check which mode your camera is in.
leeraff is offline   Reply With Quote
Old Jul 19, 2006, 3:51 PM   #6
Junior Member
 
Join Date: Jul 2006
Posts: 5
Default

tommysdad wrote:
Quote:
Have you tried seeing if the flash will fire in Aperture or Manual modes?

TD
yea it doesnt work in any mode. trust me ive tried everything.
ericmai is offline   Reply With Quote
Old Jul 19, 2006, 4:05 PM   #7
Senior Member
 
rjseeney's Avatar
 
Join Date: Dec 2004
Location: Taylor Mill, Kentucky
Posts: 2,398
Default

Do you have the flash set to active?? There is a button that has a flash icon on it. Press it, hold it down while rotating the command dial. Make sure you see the flash icon in the lcd. It would take a lot to blow a flash bulb, especially such a small unit as the pop up flash.
rjseeney is offline   Reply With Quote
Old Jul 19, 2006, 4:16 PM   #8
Junior Member
 
Join Date: Jul 2006
Posts: 5
Default

rjseeney wrote:
Quote:
Do you have the flash set to active?? There is a button that has a flash icon on it. Press it, hold it down while rotating the command dial. Make sure you see the flash icon in the lcd. It would take a lot to blow a flash bulb, especially such a small unit as the pop up flash.
yes it is.
ericmai is offline   Reply With Quote
Old Jul 19, 2006, 4:20 PM   #9
Senior Member
 
rjseeney's Avatar
 
Join Date: Dec 2004
Location: Taylor Mill, Kentucky
Posts: 2,398
Default

More than likely, your camera is defective. I'm not aware of any global issues concerning the flash unit on the d50. How long have you had the camera??
rjseeney is offline   Reply With Quote
Old Jul 19, 2006, 4:34 PM   #10
Junior Member
 
Join Date: Jul 2006
Posts: 5
Default

rjseeney wrote:
Quote:
More than likely, your camera is defective. I'm not aware of any global issues concerning the flash unit on the d50. How long have you had the camera??
a little less than a year. im sending it in to nikon tomorrow. thank goodness i still have the one year warranty.




ericmai is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:26 PM.