Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Reply
 
Thread Tools Search this Thread
Old Sep 7, 2006, 2:57 PM   #1
Junior Member
 
trendo's Avatar
 
Join Date: Sep 2006
Posts: 6
Default

hi, i've just purchased the Nikon L1 on ebay and it included a 1GBSDmemory card--80X speed ultima2 brand:Silcon Power.

When i inserted it in my camera i immediatley saw---"This card cannot be used" and the camera sort of freezes (the error will still appear though) and you cannot do anything. if i remove it i could take pictures with it's 10mb internal memory whichholds only 4images.I already formatted the memory card but the problem still remained the same.

Can anyone kindly help me out please?

Thanks.


trendo is offline   Reply With Quote
Sponsored Links
Old Sep 7, 2006, 11:08 PM   #2
Senior Member
 
Join Date: Jun 2005
Posts: 804
Default

Know anyone else with a digital camera that takes SD cards? If so, try the card in their camera. If it works, then chances are it isn't the card. Use the friend's SD card in your new camera. If it formats okay and works, then it's probably the SD card that has the problem.

No friend? Maybe a camera store will let you try out one of their cards.

If you find a fault with either the card or camera, contact the ebay merchant and work out an arrangement to return one or both for an exchange or refund.

Grant
granthagen is offline   Reply With Quote
Old Sep 8, 2006, 3:17 AM   #3
Junior Member
 
trendo's Avatar
 
Join Date: Sep 2006
Posts: 6
Default

Hello, Thanks for your reply i'm going to a camera store this weekend and check it out. Will keep you informed.

Thanks.
trendo is offline   Reply With Quote
Old Sep 10, 2006, 3:03 AM   #4
Junior Member
 
trendo's Avatar
 
Join Date: Sep 2006
Posts: 6
Default

I went to the camera store yesterday and the salesman told me that the memory card doesn't fit with the camera. but he didn't want me to try other cards because they were sealed.

He also told me that if the camera was faulty there would be the "system error" not "this card cannot be used". is it true?

Thanks.

J.C
trendo is offline   Reply With Quote
Old Sep 11, 2006, 3:36 AM   #5
Junior Member
 
trendo's Avatar
 
Join Date: Sep 2006
Posts: 6
Default

I went to the camera store yesterday and the salesman told me that the memory card doesn't fit with the camera. but he didn't want me to try other cards because they were sealed.

He also told me that if the camera was faulty there would be the "system error" not "this card cannot be used". is it true?

Thanks.

J.C
trendo is offline   Reply With Quote
Old Sep 13, 2006, 3:03 PM   #6
Junior Member
 
trendo's Avatar
 
Join Date: Sep 2006
Posts: 6
Default

can anyone tell me what FAT should I use to format my card in a Nikon Coolpics L1 please?? The card is----1GB ULTIMA2 80XSPEED brand:SILICON POWER



please help!!!!
trendo is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:02 AM.