Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Reply
 
Thread Tools Search this Thread
Old Jan 14, 2008, 6:01 AM   #1
H-M
Junior Member
 
Join Date: Jan 2008
Posts: 2
Default

First of all. It's a nice camera to operate. But concerning the quality of the pictures it is a disappointment. My old Panasonic LC 70 is better. I owned a rather plastic Canon A720 which also was superior. P5100 lacks a bit "punch" and the corner sharpness is just passable. For half the price you can get a camera as good or better than the P5100 if you're just interested in getting nice pictures. It takes good pictures but för that price it would be better. Much better

I haven't decided to keep it. But my big problem is that it doesn't work well when the flash is activated. Sometimes its working ( a bit slow but ok). But most of the times the red flash lamp is blinking. No autofocus frame is visible. No help light. Can't press the trigger. It doesnt matterif the flash is needed or not. Maybe its light enough. As soon as I deactivate the flash everything works agains. It focus and I can press the trigger again

H-M is offline   Reply With Quote
Sponsored Links
Old Jan 30, 2008, 5:33 AM   #2
H-M
Junior Member
 
Join Date: Jan 2008
Posts: 2
Default

Everything is OK. I looked in the manual. Here you can read: "under some circumstances you may have the re-press the trigger several times to get it to focus".



Very bad on such an expensive camera
H-M is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 2:23 PM.