Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Reply
 
Thread Tools Search this Thread
Old Aug 26, 2005, 8:12 PM   #11
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

Ok, thanks everyone for the help.However, I discovered something tonight!IF I push down on the lens body underneath wear the pop-up flash is, the camera starts working correctl!y! It's like something is out of whack and not lined up underneath there in the lens body.*So, the question is this...Should I take this camera apart and see if I can fix it by putting it back together again? What would you do?Also, I am starting to suspect that our babysitter has something to do with this. I think the camera may have been dropped by her. It looks like the lens body is not quite lining up at the seams.*Anyway, would you take it apart?
blkdog7 is offline   Reply With Quote
Old Aug 26, 2005, 8:22 PM   #12
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

You'll need to use your own best judgement on that. Be careful if you decide to (as you have a capacitor charged up for the flash that can be dangerous, even with batteries removed).

The person I know that had the same symptoms as you with a 995 had a cracked circuit board causing his problems (and he dropped his camera before they started). He said he could get his to work intermittently by tapping on the body.

Then again, perhaps you'll get lucky and it may just be a loose connection somewhere. But, I don't know what would be involved in taking it apart (and putting it back together again).


JimC is offline   Reply With Quote
Old Aug 26, 2005, 9:23 PM   #13
Senior Member
 
KCan's Avatar
 
Join Date: Jul 2002
Posts: 1,625
Default

blkdog7 wrote:
Quote:
...Should I take this camera apart and see if I can fix it by putting it back together again? What would you do?
Quote:
.Anyway, would you take it apart?
If the camera still work correctly, I would not. I did take apart my 950 twice, to repair the lens step motor rack (it didn't focus or zoom anymore) , and to modify the flash jack, but it needs some minimum dexterity to avoid a "no return possible mistake" :G

IMO, if you can still use it, use it as that, and think about taking apart the next time it stop working. You are lucky enough to have it work again , right?
KCan is offline   Reply With Quote
Old Aug 26, 2005, 9:29 PM   #14
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

Well, I* really can't use it very effectively the way it is now. I need to put pressure on the lens body on the top to make it work. As soon as I put pressure on the top of the lens body the LCD kinda blinks and suddenly the image in the viewfinder goes from dark to normal. It is very bizarre. And, if I move the camera slightly, it goes back to dark. So, something is not liing up correctly inside that lens body. Ugh!I might take my chances and try to take it apart. What to do, what to do...
blkdog7 is offline   Reply With Quote
Old Aug 26, 2005, 9:30 PM   #15
Senior Member
 
KCan's Avatar
 
Join Date: Jul 2002
Posts: 1,625
Default

FYI, this is what the 950 looks like inside the lens/flash half :


Attached Images
 
KCan is offline   Reply With Quote
Old Aug 26, 2005, 9:58 PM   #16
Senior Member
 
KCan's Avatar
 
Join Date: Jul 2002
Posts: 1,625
Default

recently, I found on the net a 950 service manual, which shown parts and explode view, but not for 995 , may be because the 950 is more popular. But there are websites which sell service manuals for around 10-20 $, if you like to get one.
KCan is offline   Reply With Quote
Old Oct 4, 2005, 7:50 PM   #17
Junior Member
 
Join Date: Oct 2005
Posts: 3
Default

hi
just happened now to read your post because the same thing has happened to my 995. 3.5 yrs old. also able to get it to work by pressing on the body under the flash head.
whats going on here?/ did you ever find out anything?
terrors is offline   Reply With Quote
Old Aug 22, 2007, 2:25 PM   #18
Junior Member
 
Join Date: Aug 2007
Posts: 1
Default

Ron -

I tried this solution on my Nikon Coolpix 4300. It worked! You're awesome. Saved me a big bill for a new camera.


Jason
paulite77 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:32 AM.