Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Reply
 
Thread Tools Search this Thread
Old Jul 12, 2005, 3:28 AM   #1
Junior Member
 
Join Date: Jul 2005
Posts: 2
Default

Hi all. Signed up for this website to see if I can get an answer to a perplexing Nikon 995 problem. Suddenly my camera went dark. Pictures are way too dark...view finder is dark... all nearly black. Can't see to fix it. When I view the pictures in Photoshop they are narly black...then I can use the brightness tool to take them all the way bright and you can tell what the picture is of...but of course it's not usable. So the camera is taking a picture..it's just taking it so dark it doesn't show up. It's black when you try to view it with the LCD display too.

I've had this camera 3.5 years, and yes, it's old..but if it's fixable I'd rather do that then shell out money I don't have, for a new camera. If anyone out there can help I'd be very appreciable!! I'm hoping it's something I've pushed and don't realize it...could it be a simple fix? Hope..hope..hope...:?
Arieanna Mermi is offline   Reply With Quote
Sponsored Links
Old Jul 26, 2005, 3:52 PM   #2
Junior Member
 
Join Date: Jul 2005
Posts: 1
Default

Hi Arieanna,

Have you tried a factory reset? Probably not since you can't see the screen.



Try this:



Put the camera in the Manual mode.

Then press the menu button twice.

Now use the down arrow 6 times.

Right arrow once.

Down arrow once.

Right arrow once.



Power down and back up. That should do it.



This is supposed to reset the whole camera to the default values. I use a 995 too. Great camera, and if mine died, I would go to ebay. I see a lot of them on there. It is still the best camera for any technical work (i.e. telescopes, microscopes, very close macro, etc.)



http://www.pbase.com/packrat



Good luck,

Ron N.


















Packrat is offline   Reply With Quote
Old Aug 25, 2005, 8:41 PM   #3
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

Hi! I too have had the Nikon 995 for about 3 years and it just suddenly went dark! All the photos are dark, everything is dark through the viewfinder.* It's taking photos, and I can 'kinda' see what they are, but the photos are just plain dark!*The menu system shows up as it should in the LCD, only the information that is scene through the lens on the LCD monitor is dark. All other information on the LCD appears normal (menus, etc.)I have reset the Camera and I have even reloaded the 1.7 firmware and I still have not been able to resolve this issue. I really love this camera, and I don't want to buy a new one! Any ideas?
blkdog7 is offline   Reply With Quote
Old Aug 25, 2005, 8:52 PM   #4
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

I don't know if this helps or not, but this is what the pictures are looking like directly out of the camera:
blkdog7 is offline   Reply With Quote
Old Aug 25, 2005, 8:53 PM   #5
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

Also, it says "3:2" on the little LCD on top. I don't remember this being there.Is this a correct setting?
blkdog7 is offline   Reply With Quote
Old Aug 25, 2005, 9:56 PM   #6
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

Ok, nevermind that 3:2 setting comment. I got rid of that.*Anyway, help!
blkdog7 is offline   Reply With Quote
Old Aug 26, 2005, 7:33 PM   #7
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

It's probably either the CCD sensor, some of the related circuitry, or a stuck aperture/shutter if the LCD is working OK.

The last time I saw anyone with a similar problem that sent a 995 back to Nikon, it was $200 to repair (his problem turned out to be a cracked circuit board).


JimC is offline   Reply With Quote
Old Aug 26, 2005, 8:24 PM   #8
Junior Member
 
Join Date: Aug 2005
Posts: 9
Default

That is not good news! The thing is, nothing happened to the camera. It was never dropped or hit, or anything. It just started doing it, just like that.*This is actually quite devastating. We rely heavily on this camera for Ebay. Arrgh!*
blkdog7 is offline   Reply With Quote
Old Aug 26, 2005, 8:34 PM   #9
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Well, it's not just Nikon. If almost anything goes wrong with a camera nowadays outside of warranty, you'll get it with a bill that's around that amount.

If you've already tried resetting the camera, etc., then it's probably a component failure of some type.

Just for the heck of it, make sure to try different batteries and memory card, and use all dials, switches and buttons in case some oxidation is under one causing a problem.

But, if everything else works fine (except that you don't see any signal from the sensor in the LCD Display, with all of your photos black), I'd say it's more likely a component failure of some kind.

If the signal from the sensor isn't making to the display, the most likely causes are thatthe sensor is bad, something else is impacting the signal (failed component), or the CCD can't see any light because of a stuck aperture or shutter.


JimC is offline   Reply With Quote
Old Aug 26, 2005, 8:57 PM   #10
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

P.S.

I see about 10 Coolpix 995 listings on Ebay right now. Checking completed sales, you'd probably able to buy a used one for about what Nikon is likely to chart to fix one.


JimC is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:57 AM.