Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Nikon

Reply
 
Thread Tools Search this Thread
Old Jul 15, 2006, 11:55 AM   #1
mhw
Junior Member
 
Join Date: Jul 2006
Posts: 2
Default

My camera was working fine, then the next time I went to use it, the picture looks skewed and blurred in the viewfinder and when the picture comes out. What could be the problem...???
Attached Images
 
mhw is offline   Reply With Quote
Sponsored Links
Old Jul 15, 2006, 11:23 PM   #2
Senior Member
 
Join Date: Jun 2005
Posts: 804
Default

Your camera could be a candidate for free repair under the bad ccd recall that has been issued by Nikon. Check out this thread:

http://www.stevesforums.com/forums/v...mp;forum_id=21

Grant
granthagen is offline   Reply With Quote
Old Jul 17, 2006, 1:52 PM   #3
mhw
Junior Member
 
Join Date: Jul 2006
Posts: 2
Default

:-)Thank you so much, I called Nikon and they directed me to the website with the Service Advisory, I just filled out the form and shipped my camera off (with my fingers crossed)!!! THis probably saved me at least a couple hundred dollars!!! I just hope I get it back for my beach trip.THX, MHW
mhw is offline   Reply With Quote
Old Jul 22, 2006, 12:09 PM   #4
Junior Member
 
Join Date: Dec 2005
Posts: 11
Default

I just received my CP5700 from Nikon repair. It had the problems many other users have described at this forum....streaky lines, image blurring and color fringes. I shipped it back to Nikon on July 11 per their recall notice:

http://support.nikontech.com/cgi-bin...mp;p_topview=1

and they returned it promptly on July 22. It works great, just like new.

Hooray Nikon!!
owlpoop is offline   Reply With Quote
Old Dec 17, 2008, 9:18 PM   #5
Junior Member
 
Join Date: Dec 2008
Posts: 1
Default

I found this website while searching for the topic " Nikon 5700 problems" and with the info here I sent in my 5700 to Nikon and they replaced the CCD under " Goodwill".

Although this thread is old, Nikon is still repairing the cameras. Mine was returned today, 17 Dec, 08.

Go to www.Nikonusa.com and you should find the link under Service and Support or search using the model of your camera to see if there are any bulletins for it.



Thanks for the help.


Baja16SS is offline   Reply With Quote
Old Nov 18, 2009, 4:53 PM   #6
Junior Member
 
Join Date: Nov 2009
Posts: 5
Default Same problems

Well everyone out here I just want to say thank you for directing me in the right direction on getting my Nikon 5700 fixed for the same problems... I have not been able to use it for 2 years because I did not have the funds to really spend and I have 2 other Nikon cameras not as nice that I could use... but I really miss my good one... I sent it off today 11/18/09 I will keep ya'll informed on how it goes... again thanks for the info ya'll made my day yesterday when I stumbled upon this great information on a recall!
rolltidemattox is offline   Reply With Quote
Old Nov 18, 2009, 5:08 PM   #7
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Thanks for posting. Welcome to the forums, and please let us know how it works out for you.
JimC is offline   Reply With Quote
Old Nov 19, 2009, 7:10 PM   #8
Junior Member
 
Join Date: Nov 2009
Posts: 5
Default

Thanks Jim for the welcome and I will keep ya'll informed on what happens when I receive the camera back... Again Thanks To All!

Last edited by rolltidemattox; Nov 19, 2009 at 7:13 PM.
rolltidemattox is offline   Reply With Quote
Old Nov 20, 2009, 4:40 PM   #9
Senior Member
 
Join Date: Mar 2004
Location: PA
Posts: 109
Default

I have the 5700 myself and it had the same problem about a year ago. I also sent it back and they fixed it free of charge. For an old camera, I was impressed that Nikon did this.
__________________
Nikon D5000 with 18-55, and 55-200 vr lens
Nikon SB 600 flash
Nikon S640
Nikon Coolpix 5700
Canon Elan SLR

Glenn
Blueberry is offline   Reply With Quote
Old Dec 1, 2009, 9:22 PM   #10
Junior Member
 
Join Date: Nov 2009
Posts: 5
Default

Hello everyone, I just wanted to keep everyone up to date on my camera... sent it off around the 18th of November with delivery 5 days... now remember we had the Thanksgiving holiday but Nikon sent me and e-mail along with a letter in the mail about the cost of repair which was $0.00 dollars... I can also keep track on it through their website.. I have not received it as of today 12/1/09 but when I do I will let you know how it looks... I cannot wait to get my good camera back... Again Thanks everyone for the information
rolltidemattox is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:20 PM.