Go Back   Steve's Digicams Forums >


Reply
 
LinkBack Thread Tools Search this Thread
Old Jul 16, 2006, 1:54 PM   #1
Junior Member
 
jkmeye's Avatar
 
Join Date: Jul 2006
Posts: 2
Default

After 3 years of perfect function, my D-550 suddenly stuck in "no flash" mode. I believe it is not a hardware issue as the button works for all other functions. With the camera open, when I press the flash button once, it shows the "no flash" icon - further presses have no effect. In menu mode, this button works fine. I turned on the "reset settings" , I took the batteries out and let the camera sit for several hours, I remove and replaced the media card - none of this worked.Any thoughts as to if this is a software or motherboard issue, and what I might do to fix it? Is there a "hard reset" equivalent for an Olympus digicam?Thanks!
jkmeye is offline   Reply With Quote
Sponsored Links
Old Aug 26, 2006, 6:26 PM   #2
Junior Member
 
al_savage's Avatar
 
Join Date: Aug 2006
Posts: 7
Default

I think it likely that the popup flash's mode switch is stuck.

On a normally-operating D-550, if you manually hold down the popup flash, and then use the flash menu button, only "no flash" will be shown as an option. This duplicates your symptom, so I'd look at the switch that senses whether the popup flash is in the up or down position.
al_savage is offline   Reply With Quote
Old Aug 26, 2006, 7:54 PM   #3
Junior Member
 
jkmeye's Avatar
 
Join Date: Jul 2006
Posts: 2
Default

Thanks for the suggestion - I am not certain what mechanism the D-550 uses to sense if the flash is up or down - I cleaned and probed every exposed surface when the flash was up, but did not identify a specific switch mechanism and was without success.
jkmeye is offline   Reply With Quote
Old Aug 26, 2006, 10:34 PM   #4
Junior Member
 
al_savage's Avatar
 
Join Date: Aug 2006
Posts: 7
Default

Yeah, I just shined a flashlight under the popup and didn't see anything obvious either. Looks like surgery time.
al_savage is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 2:06 PM.