Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Olympus (https://forums.steves-digicams.com/olympus-28/)
-   -   two failures on Olympus C5060 (https://forums.steves-digicams.com/olympus-28/two-failures-olympus-c5060-16678/)

queenjam Nov 28, 2003 5:40 AM

two failures on Olympus C5060
 
potential buyers, beware

don't buy this camera.

I bought C5060 (serial no. 286101120) on Nov 9, 2003, from Alan Photo (Sim Lim Square, Singapore). The camera failed after 5 days. The buttons were not responding. The camera was totally useless. Alan refused the exchange and told me to bring the camera to Olympus Singapore. Olympus replaced the camera on Nov 26. This replacement camera (serial no. 286101142) failed also after only two days of use. Both cameras had the same problem. I think there is a software conflict with the buttons. Olympus still could not figure out why both failed.

queenjam

DarkThrone Nov 28, 2003 8:05 AM

Tsk tsk... Too bad... Luckily here in the Phils. I purchased my Oly C-740 from a good dealer, she replaced my unit with no questions asked after a week, the defect was that I couldn't go higher than 1 sec in exposures.

I think that Alan Photo knew that there was something wrong with the unit, hell, five days and he won't accept it? That's weird, especially in Singapore.

I hope you get a better replacement, one that would rid you of this horrible experience. :wink:

Mike_PEAT Nov 30, 2003 10:44 PM

Just because you have problems with the 5060 in your part of the world, doesn't mean that 5060's in other parts of the world will have problems. It could be that the firmware for your part of the world does have a glitch, but I've heard nothing but good things from other 5060 owners (mind you none were from your part of the world).

KuoH Dec 4, 2003 9:13 PM

You do know that to go higher than 1" on the 740 you have to be in M mode right?

KuoH

Quote:

Originally Posted by DarkThrone
Tsk tsk... Too bad... Luckily here in the Phils. I purchased my Oly C-740 from a good dealer, she replaced my unit with no questions asked after a week, the defect was that I couldn't go higher than 1 sec in exposures.


spacedog Dec 16, 2003 7:47 AM

buttons on the 5060
 
Hi All,
My first post in here.
I too have had a similar problem with the buttons on the camera failing after about 5 days, in its favour the photos taken before the problems with the buttons are great.
I bought my camera in Australia, unfortunately one of the first 400 that were brought into the country.
I was told that there would be aprox a 10 working day turnaround to get it fixed.......hmmmm
Olympus has had the camera now for 3 weeks and I still haven't heard from them as to when Iím getting it back.
Itís a great camera but it looks like there are probably a few teething problems that Olympus should have solved before releasing this camera.
I did have my suspicions that some was wrong after the delayed release.

AGSouza Dec 16, 2003 3:42 PM

Failure in OLYMPUS C5060, buttons
 
It is here my first postage, and what has to tell it is that I had a great deception with this model C5060, acquired in it USA, therefore the same problem with the buttons of the olympus C5060 also happened with me, after having done less than 40 pictures, which I got to transfer for the computer, with great quality, demonstrating to be a great camera and that satisfies fully when being with this it records problem that is happening...!

The camera is totally crazy the buttons they answer different from your original function, the leds of the green and yellow viewfinder are the all lit time, the dial is rotated for former. of P for A, he discharges the alone picture without having pressed the shot button etc..

In that situation, the battery becomes exhausted quickly, noticing an abnormal heating of the camera besides, it seems to be me problem of CI (integrated circuit) in short or more simply failure of the internal software.

I am awaiting another one for change for the disabled camera,

Will it be that the same problem will also happen with second?


All times are GMT -5. The time now is 8:47 AM.