Go Back   Steve's Digicams Forums >

Reply
 
LinkBack Thread Tools Search this Thread
Old Sep 18, 2010, 5:34 PM   #1
Member
 
jacobt's Avatar
 
Join Date: Nov 2009
Location: Austin, TX
Posts: 92
Default Botanical garden

Went to the botanical garden today. I was surprised to see all these pretty lotus flowers. All these were using E30/50-200mm.
Attached Images
     
jacobt is offline   Reply With Quote
Sponsored Links
Old Sep 18, 2010, 6:46 PM   #2
Senior Member
 
Join Date: May 2005
Location: OKLAHOMA
Posts: 200
Default

Beautiful shot and quite interesting effects.
quinton is offline   Reply With Quote
Old Sep 18, 2010, 7:20 PM   #3
Senior Member
 
Steven R's Avatar
 
Join Date: Apr 2005
Location: Tampa, Florida
Posts: 5,926
Default

Beautiful!
Steven R is offline   Reply With Quote
Old Sep 18, 2010, 10:12 PM   #4
Senior Member
 
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,589
Default

These are all great, but the first and last ones I really like. Beautiful.
Greg Chappell is offline   Reply With Quote
Old Sep 19, 2010, 10:34 AM   #5
Member
 
jacobt's Avatar
 
Join Date: Nov 2009
Location: Austin, TX
Posts: 92
Default

Thanks for the compliments.

Greg, I like your arboretum flow shots too.

Here are a couple more...
Attached Images
    

Last edited by jacobt; Sep 19, 2010 at 10:43 AM.
jacobt is offline   Reply With Quote
Old Sep 19, 2010, 7:26 PM   #6
Senior Member
 
HarjTT's Avatar
 
Join Date: Aug 2004
Posts: 4,555
Default

Jacob

Thanks for posting.. very nice !
HarjTT is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 3:31 AM.