Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Olympus dSLR (https://forums.steves-digicams.com/olympus-dslr-40/)
-   -   Broken Fl50 ... (https://forums.steves-digicams.com/olympus-dslr-40/broken-fl50-144301/)

HarjTT Jul 21, 2008 4:00 PM

Hi Guys

I've ended up with a broken FL50 - I'd used it for the fashion shoot in th city last month and becuase it was on a light stand it and the stand ended up hitting the ground on 3 occassions. I had thought I was extremely lucky as it was still working but I didn;t realise that it no longer switches to TTL or manual mode and is in constant high speed mode. Has anyone tried repairing one or should I just call Oly and see what they say regards a repair ?

Cheers

Harj

:? :O



boBBrennan Jul 21, 2008 4:44 PM

................hi Harj,

It has been a while, I just want to say hi and say, "I hope all else is well and that you still are having fun".

Sorry to hear of the FL50, I have no advice but for contacting Oly. I have a FL36 now for quite a while and the lock ring has broken, I've 'super glued' that several times but then that won't solve your FL50 problem.

Wishing you good luck with the FL50, let us know.
__________
boBBrennan

HarjTT Jul 21, 2008 5:51 PM

Hi Bob

I was thinkign about teh super glue.. been messing about with bits of plastic and even wood to see if that would work!

Picturewise, I;ve not had much time to take pics - I took a few shots on the weekend but nothing that stands out. The weather here (apart from teh last few days) has been truly poo !

Cheers

Harj

:? :O

gwillys Jul 22, 2008 6:38 AM

hi Harj, :-),probably no help, but heres some parts: http://www.uscamera.com/fl40_50.htm






All times are GMT -5. The time now is 8:14 PM.