Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Olympus dSLR (https://forums.steves-digicams.com/olympus-dslr-40/)
-   -   ME 1 users ... if any ? (https://forums.steves-digicams.com/olympus-dslr-40/me-1-users-if-any-103516/)

gaggu Oct 11, 2006 3:41 PM

Hi all,

I have been thinking about getting the ME 1 magnifier for E 500.

Has anybody here used it ? Opinions ... if any ?

Cheers,
--
Gaggu

-=edge=- Oct 11, 2006 4:41 PM

i use it and it does make a difference albeit a small one, i think it helps out a lot....Olympus kinda messed up with the viewfinder on the E500, hopefully the next pro body has a better VF

gaggu Oct 11, 2006 4:48 PM

Thanks Edge :)

Cheers,
--
Gaggu

Mikefellh Oct 13, 2006 7:40 AM

I originally bought the ME-1 for my E-300 to help with manual focusing and using the Lensbaby. The first time I use the ME-1 on the camera with the Lensbaby I found I COULDN'T focus!!! I had to take the ME-1 OFF THE CAMERA in order to do manual focusing with the Lensbaby...so the ME-1 didn't fit my needs.

Personally, I would have considered the Olympus VA-1 angle (which does 2x) if the unit went on a 45 degree angle instead of a 90 degree angle (I tried the VA-1, but my neck was sore from using it because to use the camera normally you have to look down at your feet).

gaggu Oct 13, 2006 9:43 AM

-Mikefellh

What about manual focussing without Lensbaby ?
Does it help ?

Cheers,
--
Gaggu

Mikefellh Oct 13, 2006 1:39 PM

I never need to do MF focusing, AF always works for me.

I do have a 400mm OM lens, but I haven't been in a situation where I've needed it recently.


All times are GMT -5. The time now is 3:34 AM.