Go Back   Steve's Digicams Forums >

Reply
 
LinkBack Thread Tools Search this Thread
Old Jul 3, 2010, 11:50 PM   #1
Senior Member
 
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,589
Default Went for a swim today....

No pool needed..



Fortunately, it just lasted for two races. All images shot with the E30 and 50-200 SWD, covered for the first two races with an OP-Tech rain sleeve, and me with a one-use plastic poncho..







After the rain cleared out, I had to keep ISO's high to keep movement in check, so this was a great set of images to process using my new, upgraded Adobe Camera RAW with the much improved noise filter.

ISO 1250..





ISO 2000..







ISO 1600..





Greg Chappell is offline   Reply With Quote
Sponsored Links
Old Jul 4, 2010, 8:37 AM   #2
Senior Member
 
zig-123's Avatar
 
Join Date: Dec 2006
Location: Cape Cod, Massachusetts
Posts: 5,190
Default

Yikes!!

Racing horses in the rain looks downright dangerous.

Zig
zig-123 is offline   Reply With Quote
Old Jul 4, 2010, 10:36 AM   #3
Senior Member
 
mtclimber's Avatar
 
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143
Default

Zig-

Or at least pretty darned muddy!

Sarah Joyce
mtclimber is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 8:08 AM.