Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus dSLR

Reply
 
Thread Tools Search this Thread
Old Aug 20, 2007, 9:31 AM   #1
Junior Member
 
Join Date: Aug 2007
Posts: 1
Default

It seams to me that when i turn of camera it still takes power from battery.I charge the battery take i few (10-50) pictures battery is still shows full then i turn off the camera an leave it, after a day i turn on the switch an camera is dead.I've tested the battery at my brothers e-510, he toke more than 200 pics with LCD always on and it was still full so the battery is not the problem.Since i both the camera on e-bay from America and i don't have worldwide warranty and Olympus service in my county is bad i and expensive i first have to try to fix the problem on my own.Does anybody have experience with this problem.

Thanks Filip







Filipinac is offline   Reply With Quote
Sponsored Links
Old Aug 20, 2007, 10:50 AM   #2
Senior Member
 
jorgen's Avatar
 
Join Date: Apr 2006
Posts: 200
Default

You should be able to take many hundreds of photos with the e-500 before charging the battery. I doubt you can fix this yourself.

Jorgen
http://www.photoblog.com/jorgen

jorgen is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:55 AM.