Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus dSLR

Reply
 
Thread Tools Search this Thread
Old Apr 11, 2008, 1:58 AM   #1
Member
 
jewel45's Avatar
 
Join Date: Oct 2006
Posts: 93
Default

Hey all
Finally back on board and with my new Olympus E500 and array of lenses. Its been a while since my last post and Im eager to post a few of my pics that Ive taken with my new camera for critque. See you soon
jewel45
jewel45 is offline   Reply With Quote
Sponsored Links
Old Apr 11, 2008, 8:11 AM   #2
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Note that you started this thread in our Olympus Forum (which is setup for Olympus Point and Shoot type cameras).

So, I moved the thread down to our Olympus dSLR forum, which is setup for Olympus models like your E-500.

Congrats on the new camera and lenses.

JimC is offline   Reply With Quote
Old Apr 11, 2008, 3:10 PM   #3
Senior Member
 
gwillys's Avatar
 
Join Date: Feb 2008
Posts: 247
Default

hi julie, welcome back. post some pics. lets see what you got.
gwillys is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:10 AM.