Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus dSLR

Reply
 
Thread Tools Search this Thread
Old May 20, 2008, 11:54 PM   #1
Member
 
Join Date: Jul 2006
Posts: 68
Default

Hey eveyone,

So I dropped my camera while it was in the camera bag about a week ago. Unfortunatelythe bag slipped off my shoulder and took a nosedive on the concrete.

upon hitting the ground, the lenscap got forced inwards and broke my uv filter. I tended to the matter right away upon inspection. I held the camera lens down, forced the cap off and got all of thefilter glass out of there. After blowing on the filter to remove the (glass) dust from the broken filter, I rinsed the lenscap out thoroughly and allowed it to dry.

Anyway, those measures seem to have worked. there is no visible damage to the lens. The autofocus seems to work perfectly fine at different focal lengths (although I haven't tested it close to a subject yet). I did experience some problems when trying to focus with the AF area set to the right (ie not centre) in some low basement light, but not enough to be certain.

In this situation is there anything particularly common or specific that I should be looking for? Apparant scratches are a non-existent, I'm more worried about the internal electronics etc.
Pickwick is offline   Reply With Quote
Sponsored Links
Old May 21, 2008, 1:15 PM   #2
Member
 
Join Date: Mar 2008
Posts: 37
Default

Well I'm no expert on dropping my camera (thankfully) but I'd say you're ok. I'm not sure if there's any diagnostic tests that can be performed on the electronics of the lens or camera body short of talking it to an authorized repair center. But I know I'd be glad I had that UV filter on there to take some of the force out of that fall!
Rileigh is offline   Reply With Quote
Old May 21, 2008, 8:55 PM   #3
Senior Member
 
-=edge=-'s Avatar
 
Join Date: Jan 2006
Posts: 220
Default

that is the number one reason to use a UV filter on your lenses and a good reason to invest in a good padded bag like a lowepro. I think your camera and lens will be fine
-=edge=- is offline   Reply With Quote
Old May 22, 2008, 2:10 PM   #4
Senior Member
 
HarjTT's Avatar
 
Join Date: Aug 2004
Posts: 4,533
Default

Hi Pick

I think you'll find that the 14-54 can take quiet a drop and be ok (trust me I know from experience). I would however, get the E510 checked to make sure nothings been damaged . I found that over time my E1 which had the 14-54 attached to it at the time it bounced down 3 steps an escalator lens first eventually developed a couple of serious issues. The mistake I made was noe sending it in to Oly to make sure it was ok. In the end my E1 became too unrealiable for me to use and I was forced to get an E3.

Cheers

Harj

: o )>
HarjTT is online now   Reply With Quote
Old May 23, 2008, 3:58 PM   #5
Senior Member
 
Dangerous Brian's Avatar
 
Join Date: Apr 2005
Location: Scotland
Posts: 140
Default

Forced to get the E3 Harj. lol :homey:

We all do a hommer some time andI guess it's luck how good or bad u come out.

anyway maybe you should phone olympus and see how much they charge for inspection. and can you do without camera.

or better still do a harj and buy the E3 lol


Dangerous Brian is offline   Reply With Quote
Old May 24, 2008, 4:37 AM   #6
Senior Member
 
HarjTT's Avatar
 
Join Date: Aug 2004
Posts: 4,533
Default

Hi Brian,

You got me laughing reading your reply. The E1 was and is still working but 10 + months after the drop it started to do some realy weird things - like loose communication with the lens, the LCD would stay powered on without the battery - i did get 10 + good months of shooting with it but by Jan this year it wasn't reliable enough for me and I was hoping to wait and see what the Panalieca pro would be like before buying another cam.

Cheers

HarjTT

:? :O
HarjTT is online now   Reply With Quote
Old May 27, 2008, 1:22 PM   #7
Member
 
Join Date: Jul 2006
Posts: 68
Default

Thanks for the suggestions, I'll call olympus and see what they can do. Who knows? Maybe they'll find a reason for me to replace it with the E520 .
Pickwick is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:09 PM.