Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Olympus dSLR

Reply
 
Thread Tools Search this Thread
Old Jun 13, 2008, 5:12 PM   #1
Administrator
 
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,378
Default

Olympus has released Firmware Version 2 for the Olympus E-3. improving Auto White Balance. See this page for more details:

http://www.olympus.co.jp/en/support/...firm/e1/e3.cfm

JimC is offline   Reply With Quote
Sponsored Links
Old Jun 14, 2008, 4:37 AM   #2
Senior Member
 
HarjTT's Avatar
 
Join Date: Aug 2004
Posts: 4,531
Default

Thanks Jim!

Just wondering if they added any other functionality to the update - like give FC with manual lenses! Will see what they have updated and fixed.

Cheers

Harj
HarjTT is offline   Reply With Quote
Old Jun 14, 2008, 5:52 AM   #3
Senior Member
 
Mikefellh's Avatar
 
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707
Default

Nope, nada. People who have already upgraded have found nothing new.

Olympus is very skimpy with firmware upgrades, fixing only what makes their product look bad by not working correctly, rather than fixing what users complain about.

Mikefellh is offline   Reply With Quote
Old Jun 14, 2008, 11:15 AM   #4
Senior Member
 
tkurkowski's Avatar
 
Join Date: Apr 2007
Location: Maryland, USA
Posts: 3,625
Default

Hi, Mike

I assume you're tracking the DPReview threads on this.Do they say that the WB correction is worth the trouble? Because a firmware upgrade is a pain in the rear if you've changed a lot of the settings from their defaults.

Ted
tkurkowski is offline   Reply With Quote
Old Jun 14, 2008, 12:49 PM   #5
Senior Member
 
HarjTT's Avatar
 
Join Date: Aug 2004
Posts: 4,531
Default

I'm going to give this fw update a complete miss if its just fixing a WB issue. I'd rather they pulled their fingers out and added some additional functionality, fix any AF issues and improve it if possible .

HArj

:? :O
HarjTT is offline   Reply With Quote
Old Jul 6, 2008, 7:08 PM   #6
Senior Member
 
HarjTT's Avatar
 
Join Date: Aug 2004
Posts: 4,531
Default

Flash WB on my E3 is really out when your working in the studio and esp against a white paper background, so I'm wondering if this update would also fix that ? The Flash WB is set to 5600K but when you take it into any PP app, its quiet a bit off and the white paper is not white but rather a cream. In ACR/LR setting a custom WB against the white paper it shows it as being 4800K which just seems to be a wee too out for me.

Cheers

HArj

:?
HarjTT is offline   Reply With Quote
Old Jul 12, 2008, 3:14 AM   #7
OCD
Senior Member
 
Join Date: Jul 2007
Posts: 101
Default

tkurkowski wrote:
Quote:
Hi, Mike

I assume you're tracking the DPReview threads on this.Do they say that the WB correction is worth the trouble? Because a firmware upgrade is a pain in the rear if you've changed a lot of the settings from their defaults.

Ted
The new WB Firmware update does NOT cancel your saved settings as in previous Firmware updates.

As regards the update itself this is a match made in heaven for the E3 and ACR, which now has no trouble showing thumbs and doing conversions with accurate colour based on 'Camera Settings' nine times out of ten for normal subjects.



Steve
OCD is offline   Reply With Quote
Old Jul 12, 2008, 7:33 AM   #8
Senior Member
 
tkurkowski's Avatar
 
Join Date: Apr 2007
Location: Maryland, USA
Posts: 3,625
Default

OCD wrote:
Quote:
The new WB Firmware update does NOT cancel your saved settings as in previous Firmware updates.
Hallelujah! Thanks for the update, Steve!

Ted
tkurkowski is offline   Reply With Quote
Old Aug 2, 2008, 3:36 PM   #9
Senior Member
 
HarjTT's Avatar
 
Join Date: Aug 2004
Posts: 4,531
Default

Hi Guys

I've updated to FM 1.2 and the AWB looks as if its working the same as before - so to my eyes no real improvement. Has anyone else noted an improvement or not ? I'm going to take the E3 out tomorrow and see how it performs, inc in studio.

What I did find weird was prior to the upgrade I made a few changes to the camer's setup and saved them. Upgraded to 1.2 and the settings were back to what they were before I made the changes.

Cheers

Harj

:? :O

PS

If your shooting with studio lights - update to 1.2 as it fixes the Flash WB issue as well - white now is white!
HarjTT is offline   Reply With Quote
Old Aug 4, 2008, 2:10 AM   #10
OCD
Senior Member
 
Join Date: Jul 2007
Posts: 101
Default

I found a significant improvement in Auto WB, perhaps best seen across a days work of different subjects. The final hurrah comes with the ACR E3 profile in Adobe's new Standard Profile concept. Now not only is the WB more accurate, but the 'famous' Oly colours and tone are reproduced in RAW conversion without much further fiddling.

Re your camera resetting some functions. The previous Firmware updatedumped the whole camera backto its factory defaults, saved resets and all.But all your settings should have been saved if you had them in Reset 1 or 2 and My Mode.



Steve
OCD is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:46 PM.